Colibri iMX6ULL: UAP0 interface - WiFi autoconnect - Double connection

Hi team,

Testing the WiFi for a customer, I’m having some issues that I hope you can help me with:

  1. I believe by default, our BSP adds both mlan and uap interfaces whenever we start the WiFi, and that generates 2 different hashes in connmanctl almost identical, however one of them try to connect to the uap (failing) while the other works when using the connect command, a bit annoying. I’ve documented that here, but if you could provide some more info on the topic, as well as how can we disable the uap0 interface by default (using ifconfig uap0 down works until it is wifi is scanned again), appreciated. Also, not sure in what cases the uap0 is used so any more info in the topic is appreciated (I’ll try to update the documentation then).
  2. Is there anyway to get the both WiFi and the Ethernet automatically connected? I’ve managed to autoconnect to the WiFi if I don’t have an Ethernet cable, but if the Ethernet is connected when restarting, only the Ethernet is connected. If I disconnect the Ethernet, then it automatically connects but customer needs both at the same time. For now, using the connect command is the only way we could manage to get both working at the same time, but we want to remove that step. I’ve tried with "AutoConnect = True", but there doesn’t seem to have any difference.

Thanks and regards,
Alvaro.

Regarding the second question, I found that the following config from connman, seems to be working alright. In /etc/connman/main.conf, the following settings worked for me:

[General]

PreferredTechnologies=wifi,ethernet
SingleConnectedTechnology=false

This worked for me, but for future reference I also believe the AlwaysConnectedTechnologies might be a better choice depending on the case.

Source: https://wiki.archlinux.org/index.php/ConnMan