Colibri iMX6ULL: Resistive touchscreen

Hi team,

I’m having some issues using the resistive touchscreen in the Colibri iMX6ULL. The screen is not responsive in the calibration test, and I’m unsure if it’s supported out of the box. I’m using the EDT 7" Display.

AFAIK, the AD7879 is the resistive touch controller used and the calibration application correctly detects it, but it doesn’t react to any touch input. The atmel_mxt_ts is the capacitive touch controller which is not enabled by default and it should stay that way.

Also, to confirm is not a HW issue, I tried the same setup with a Colibri iMX6 and it worked perfectly. Also, the resolution is correctly setted through Uboot.

I’ve attached dmesg but here is the reference to AD7879 (default environment):

root@colibri-imx6ull:~# cat dmesg.txt | grep AD7879
[    1.628839] input: AD7879 Touchscreen as /devices/soc0/soc/2100000.aips-bus/21a4000.i2c/i2c-1/1-002c/input/input0    

Here is the output for lsmod, although checking colibri-imx6ull_defconfig, TOUCHSCREEN_AD7879 and TOUCHSCREEN_AD7879_I2C are loaded directly in the kernel ([=y]), not as module.

root@colibri-imx6ull:~# lsmod
Module                  Size  Used by 
bluetooth             338752  2
usb_f_rndis            15638  2
u_ether                12433  1 usb_f_rndis
mcp251x                10164  0
can_dev                12635  1 mcp251x
libcomposite           44440  10 usb_f_rndis
configfs               30565  3 usb_f_rndis,libcomposite

What am I missing?

Thanks and best regards,

It seems it was a HW issue from the module, sorry for taking your time.