Colibri iMX6ULL Recovery Mode USB issue?

I am trying to update the uboot of my colibri imx6ull system-on-module to resolve the issue I am facing over here. I am trying to get into recovery mode with by shorting certain pins on system-on-module or by entering into uboot command prompt and typing command bmode usb. I don’t have any display.

Then, i have connected the usb to my PC running Ubuntu 16.04 (64 bit). tail -f /var/log/syslog returns the output given below:

Looks like there is no /dev device node being assigned to the usb. I am not sure if it should. I entered in uboot and run bmode usb command to get into recovery mode and then i tried the -d command but nothing works. See the image in the attachment. Please help with the instruction to get the board boot.


I have compiled everything from scratch by following instructions over here.

I am using viola board and my viola board doesn’t have following components soldered. So, our team has soldered R17, R55, R56 and a X4.

@marcel.tx @jaski.tx Please help.

Hi @abhiarora

Could you provide the version of the viola carrier board?

When the module is in recovery mode, you should see the following device when in dmesg log.

Jun 12 11:08:34 xx kernel: [ 9000.840061] usb 1-1.3: New USB device found, idVendor=15a2, idProduct=0080
Jun 12 11:08:34  xx kernel: [ 9000.840066] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jun 12 11:08:34 xx kernel: [ 9000.840069] usb 1-1.3: Product: SE Blank 6ULL
Jun 12 11:08:34 xx kernel: [ 9000.840072] usb 1-1.3: Manufacturer: Freescale SemiConductor Inc 
Jun 12 11:08:34 xx kernel: [ 9000.842564] hid-generic 0003:15A2:0080.0005: hiddev3,hidraw3: USB HID v1.10 Device [Freescale SemiConductor Inc  SE Blank 6ULL] on usb-0000:00:14.0-1.3/input0
Jun 12 11:08:34 xx mtp-probe: checking bus 1, device 21: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1.3"
Jun 12 11:08:34 xx mtp-probe: bus: 1, device: 21 was not an MTP device

This is correct in your case.

After this you should try to launch the recovery-linux command from this file.

@jaski.tx Yes. lsusb shows vendor id of freescale. What does your script do?

hi @abhiarora, the script will boot the module to Toradex Easy Installer, where you can choose which image you want to flash, if the module is connected to Internet. Otherwise, you can extract the tezi image to the USB key also and flash your image.

Will it update the module with bug-free (of sdcard not being detected) bootloader?

And I think you have changed your deploy output files and hasn’t updated your script. It is looking for something that is not present on the filesystem.

Yeah, you just to need the flash the CI Build bsp2.8b3 with build number99 or higher.

Ok, here you will find all the information about creating custom Linux images under the Tab “Configuration Files”.

Thanks. Enabling CI feeds in toradex easy installer and downloading 2.8b3.99 version solved the issue. However, my custom build has the buggy uboot image. Can you share uboot with bspv2.8b3.99 so that I can replace my own build uboot with yours before -o. Or Can you help me in compiling with bspv2.8b3.99?

Perfect, that the issue is solved. You can follow the instructions on this site to build your own U-boot. The Fix is committed in the 2016.11-toradex-next branch. It is important to mention, this is a development branch where we don’t provide any support.