Colibri IMX6ULL reboots after writing command Poweroff on ssh BSP2.8b6

I am working on colibri IMX6ULL with 256MB device , I have customized OS using bsp2.8b6 (without graphical user interface) and found it to be working from last 3-4 years. Now I have observed issue : whenever a poweroff command is sent over ssh the device reboots. Its is expected to go into powerdown mode but, found to be reboot. I have tried various commands like : shutdown -h now, shutdon 0, opkg update, opkg upgrade, sync, etc but no success. I also tried few Uboot commands like : reset, erase, etc; but no success. I have also flashed the device with reference image from bsp2.8b6 but, still the issue persists. The customized OS and reference OS found to be working with other devices properly for poweroff command usage. Please, let me know suggestions if any

hi @SDR ,
We recommend you to update your BSP as the one you are using is outdated.
What is the command you are using to power off the module.
Also, you mentioned that it is working on the device (Colibri iMX6ULL) with the same OS.
So, do you mean to say that the issue is happening only on a particular module?

hi @sahil.tx ,
Thank you for your reply. Currently it is not possible for us to update the BSP as we have installed our customized devices on field. I am using “poweroff” command. Yes, the same OS is working on other colibri IM6ULL device and the issue is happening only on this particular module only. Please, let me know suggestions if any

Hi @SDR ,

I tested and did not face any issue.
You can reflash the image and test again (also with the latest image).
If it still does not work you can submit RMA form.

hi @sahil.tx ,

Thank you for your reply. I have tested on other IMX6ULL found to be ok. But, facing the same issue with this particular device. I will try by flashing new version OS and update you

Hi @sahil.tx,

I have flashed imx6ull device with Latest OS from 6.0.0 and 6.3.0 on reboot the device not getting restarted so the issue is seems to be resolved with this updated OS but we are still using bsp2.6 and other devices found to be working with this bsp2.6 no reboot issues found but these two devices are found to be restart issue

please let me know suggestions if any

Hi @SDR ,
BSP 2.6 is outdated and no more supported.
I would suggest you to use latest images. In case you face the issue again with the updated image as well, you can fill the RMA form