Colibri IMX6 image load issues

I have a weird set of issues and would appreciate any advice please.

Loaded Torizon 5.3 xxx with Easy Installer 5.0 and for a SOM 512MB it loads and I get portainer to connect normally. SSH is also normal. On 256MB SOM’s the installer works in RAM + Flash and boots normal with the image still there of the installer. Portainer will not connect even though the image is the same.

Trying the OTA on SOM 512MB I can get the image flashed ok and it reboots fine for more cycles. The yaml file as std for the kiosk browser on the toradex page will not finish or som will not reboot. Manual reboot shows some unfinished docker window.

On the 256MB soms the OTA will not flash the image and a manual reboot after 1hr do not even connect ssh.

Any ideas about this weird behaviour?
Is there any way to test if the image flashed ok accept for ssh login…easy installer should ideally show this but did not see anything?

Greetings @thecatim,

TorizonCore is no longer supported on the 256MB variant of the Colibri i.MX6. This is due to issues we ran into related to the smaller memory size.

Out of curiosity how did you you flash the 256MB module with TorizonCore? We shouldn’t be publishing TorizonCore releases for this variant anymore, so it’s a bit surprising you were able to flash this.

Best Regards,
Jeremias

Thanks for replying at least I now know the reason why I wasted a lot of time trying to figure it out. This should be stated somewhere obvious…Toradex has the most documentation I have ever seen for a SOM however it’s very poorly organized and often incomplete or out of date. I work with other SOM vendors and seldom face workstopping issues and wait 13 days for a reply.

I download the installer zip mentioned into a folder and flashed it by shorting the bridge on the som…with a vnc I triggered the os update however it never came back from lala land. At no stage was there any warnings or errors.

This was to install Node-Red as a container…I assume I can install NR just on the Yocto without Docker image? (bytherway you have a NR page with a video that shows how to use a YAML and this does not work even on a 512mB as I could not install the docker yaml compiler in any way)

Thank you for replying to my issue.

1 Like

Apologies for the delayed response, this was not our intent.

As for documentation I agree some of our documentation is a bit scattered, though we are in the process of trying to revamp and reorganize our documentation website. Hopefully this helps alleviate the issue.

For the time being however for any information related to Torizon you can always start here: Torizon - Industrial Linux Software Platform

This is the “hub” of sorts for all major Torizon documentation. Here we state the hardware requirements, for the i.MX6 only the i.MX6DL is supported not the i.MX6S with the 256MB.

At no stage was there any warnings or errors.

Just to clarify we still do/have builds of Torizon available for the i.MX6S for customers to try however we don’t guarantee any functionality as it’s not a fully supported platform. I’ll see if we can make this more apparent on installation with warning or such as you suggested.

I assume I can install NR just on the Yocto without Docker image?
You should be able to. Most anything can be built and installed with Yocto given the code is available and a recipe is created (if it already does note exist).

bytherway you have a NR page with a video that shows how to use a YAML and this does not work even on a 512mB as I could not install the docker yaml compiler in any way

Are you referring to this article: Node-RED

Could you clarify which step is failing, I don’t see anything on the page about a “yaml compiler”. I’ll be happy to report the issue once i can reproduce this on my end.

Best Regards,
Jeremias

Yes the video below at 6min shows a yaml…however how could this be done with Torizon that has the lack of the yaml composer? I tried installing it however it was too hard even trying this with the other installers. I wanted to try this as I had no success getting the I2C ports exposed without this yaml recipe.
https://developer.toradex.com/knowledge-base/node-red#Get_your_ideas_off_the_drawing_board_with_NodeRED

Ahh you’re referring to the docker-compose yaml file that is used in the video. I believe there might be a misunderstanding.

The compose file is not at all required and is an alternate way to launch the red-node container. Furthermore, there shouldn’t be any installation of anything required to run the compose file. The docker-compose utility should just be on TorizonCore by default.

I was able to bring up the compose file used in the webinar video. What exact issues are you experiencing on your end?

Best Regards,
Jeremias

I will try it again with the latest version torizoncore as I tried it right after the seminar of that video and it did not work as the error was that the composer was not present…it probably is now if yours works.

I wanted to use the yaml as I have tried manually setting up NR and could not get the I2C port to expose outside of the container. I saw the yaml had some particular mapping.

Were you able to give this another attempt? Are you still experiencing any difficulties?

Best Regards,
Jeremias