Colibri iMX6 file system issue with flash

Dear all,

I have faced problems with three iMX6 System on Module (SoM) which I have installed on the Carrier Board Iris Rev.2.0. The issue reflects in changing anything I have deployed into the flash memory. This is the brief history and timeline:

After I have installed the Toradex Windows Embedded Compact 7, version 1.6-20191223 (2019-23-12), I added in :


a new DWORD EnableTrim and set value to 0. I have changed settings for display resolution 4.8 inches, installed a .NETFramework and installed my c# application, as well as other setups to make my application startup.

I have noticed that I have a problem while installing a new version of the application. I closed the application and have seen that I can’t change anything on the FlashDrive (neither delete nor add new data), cannot change any registry value or anything using the ConfigBLockEditor application. It persists the previous file/values after the system reboots.

I have entered recovery mode and tried to reinstall the latest wince version (tried with the older version as well) using Easy Installer. I have kept getting the following error:

Serial numbers of used SoMs :

Col iMx6DL 512MB IT V1.1B 10930679
Col iMx6DL 512MB IT V1.1B 10930618
Col iMx6DL 512MB IT V1.1B 10930630

Thank you all in advance!


Could try to erase flash using Toradex Easy Installer before installing WinCE image?
What is a version of Toradex Easy Installe ryou are using?
Could you please describe in details other setups ?


Hi Alex,

Usually, I am using 1.8 version of Easy Installer, and with that version when I tried to erase flash memory, I got the following error:

Also, I tried with the version 5.7 and in that case, I didn’t get any specific error but the easy installer freezes and I couldn’t select anything. Then I forcedly reboot module and tried to install the latest wince version without erasing flash memory. Installation process has begun but after few second the screen turns out blank.

My procedure described in detail:

  1. Create empty AutoRun folder in FlashDrive

  2. Change value of key HKLM\init\Launch50 from expolrer to _explorer

  3. Change value of key HKCU\ControlPanel\Sip\TurnOffAutoDeploy from 0 to 1

  4. Add a new DWORD EnableTrim with value 0 in HKLM\Drivers\SDCARD\ClientDrivers\Class\MMC_Class\High_Capacity

  5. In RegEdit import CommSettings.reg from FlashDrive/Files





  1. In RegEdit import LocalEntries.reg from FlashDrive/Files



  1. Change DateTime to UTC format

  2. Change splash screen using Update Tool

  3. With ConfigBlockEditor application, select field *ss, and change value of dbginfo from value 1 to 0

  4. With ConfigBlocEditor application, select field boor and change breakchar2 to 0x31, blockchar3 to 0x32 and blockchar4 to 0x33


If you still able to enter to eBoot menu you can try use

eraseflash 0 128kb


eraseflash filesystem

Otherwise please try

Could you please try to

  • load Easy Installer but stop process at U_boot step by pressing “space” at terminal programm right after starting recovery script
  • isuue U_boot command mmc partconf 0 1 1 0

Then reboot device and load Toradex Easy Installer

I’ve tried all of the above and nothing helped :frowning: I have erased flash succesfully and also run this command in U_boot terminal, but still having the same problem.
This is an output on Putty terminal which I got while I was trying to install WinCE image via Toradex Installer.

Hi @Mozart !

I would like to ask you to proceed with an RMA, as it can be a hardware issue.

Please follow this link and its instructions.

Best regards,

Hi @henrique.tx ,

Thank you. I will do that procedure.

Best regards

Hi @Mozart ,

We analyzed your moules and found out that they are in a Write Protect mode due to a eMMC Manufacturer issue. We now have a tool to unlock those module and also prevent others from running into this issue. It’s very easy to use, just put the Tool on a USB Stick or SD Card and it will autorun on insertion and fix the affected units.
We will make this tool available in the next few days.

Thanks, @germano.tx ! Any feedback regarding the tool?

Hi @Mozart ,

Sorry it took quite long until the developer webpage article was online…

Here you can find the tool and some explanations:

1 Like