Colibri IMX6 1.1a recovery mode

Hello all,
I’m trying to recover a colibri 1.1a which does not boot anymore due to an error updating uboot. I’ve solved a similar issue on a few other colibri 1.0 using a Colibri evaluation board 3.2 following the procedure explained in http://developer.toradex.com/knowledge-base/txx-recovery-mode :

  • Connect USB Standard B or Micro B to the X29 or X30 respectively on the Eval board and USB A to your PC.
  • Power on the Eval board.
  • Press and keep pressed (or hold) the recovery mode button SW9 and immediately press and release the reset button SW8 on the Eval board.
  • After 2-5 seconds, release the recovery mode button SW9.

After this point with our colibri 1.0 we see an entry listed in lspci. Unfortunately we see no entry with our colibri 1.1a, hence it is not possible to use update.sh to recover.
Do we have to change the procedure to recover the newer version of the imx6 using a colibri evaluation board?

Thanks!

Note that the article you reference is for Tegra based modules only.

What version of SW did you actually try to install?

Do you have any output of the failed update procedure?

I understand that the link refers to tegra modules, unfortunately I did not found any help page for the imx6 based modules. Moreover the procedure worked fine with colibri imx6 1.0.

If I understand the problem correctly with colibri 1.1, once I complete the fourth point of the procedure appears this device in lsusb

Bus 003 Device 006: ID 1b67:400f

1b67 appears to be a vendor id which refers to toradex, and it is not one of the devices update.sh looks for during the restore procedure

./update.sh  -d
Colibri iMX6 rootfs detected
config file <./imx_usb.conf>
vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf
vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf
vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf
vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf
vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf
vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf
vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf
vid=0x066f pid=0x37ff file_name=linux_gadget.conf
no matching USB device found

We used the instructions found in the page
http://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)
to compile the image and to get a update.sh tool, but the output is the same both with branch 2.7 and 2.7-next

Using a colibri 1.0 in lsusb we find the vendor id 15a2 (freescale) and update.sh works fine.

Is there a different procedure I should use to recover a colibri imx61.1?

I guess instead of lspci you rather meant lsusb. Please have a look at the following answer about the Colibri iMX6 recovery procedure.

Then you are most likely not in the recovery mode but rather the factory pre-installed Toradex Easy Installer is running. Either update the module by using the Toradex Easy Installer or make sure to actually enter the recovery mode but shortening resp. pad on the module as indicated in the data sheet or the bmode usb U-Boot command entered via serial debug console.