Colibri Eval board is not responding even after hardware reset

Hello Support Team,
I am using Col Evaluation board (V3.2B) with Col iMX6DL 512MB Com Module (V1.1A). It was working fine until I updated it with u-boot (worked before) and it has stop responding to anything since then. I am trying to recover the board but with no success. I tried to shorten the pads mention in iMX Recovery Mode but still I don’t see anything on any of the uart ports or USB cl (X29).
Not sure what else I can do here?

You shouldn’t get any output on debug UART when modle is in recovery mode. X29 is used for serial download by special utility. Such utility is included in Toradex Easy Installer package. Please follow this steps - Downloads & Installers | Toradex Developer Center

Thanks for your reply. But issue here is, I am not able to force module to go into recovery mode. I have followed the instruction on iMX Recovery Mode | Toradex Developer Center and short pads as mentioned but with no success. Any other way, I can force module to go into recovery mode?

Hi, there is no other way to recover the board then shortening the pads. Did you remove the SD Card from SD Card Slot?

Looks like I might corrupted the bootloader. I have ordered one JTAG debugger to reprogram bootloader. Can someone guide me towards the correct bootloader for it please.

I am not able to force module to go into recovery mode

Could you provide more details? How your board is connected to PC? What exactly you did? How did you identify that your board is not in recovery mode?

My board is connected to pc with UART-A using null modem cable, UART-C using ftdi cable,
And USB CL cable.
I updated my u-boot using update_uboot command and since then it’s not responding to anything.

Yes I have tried both with SD card and without SD card.

Hi @Toradex_h83

Could you answer the following questions:

  1. What is the output of when you run script on your host?
  2. What is the output of lsusb | grep -i free when you put the module in recovery mode?

Best regards,

Hi Jaski,
I ran recovery-windows script instead of Linux one to avoid any conflict as my ubuntu is running on virtual-box but they both do the same job I believe (run imx_usb).
The output is “no matching USB device found”.

Not sure if I am missing anything here?

It is difficult to tell what might be wrong.
Could you tell us how exactly did you put the module in recovery mode?
Is any led on the colibri evaluation board turned on? If yes, which one?

I tried to change the debug port from A to C and applied the patches mentioned by toradex. I then did run setupdate and update_uboot to update the uboot and since then it’s not working.
There are only 3 leds on at the moment. 2 power one and 1 near the usb otg port after plugging the usb a-b cable.

I forgot. The only way i can put board into recovery mode is by shortening the pads as i am not getting uboot to interrupt or anything else on any other ports


There are only 3 leds on at the moment. 2 power one and 1 near the usb otg port after plugging the usb a-b cable.

That’s correct. You should see a new device in the device manager. Could you share what do you see in Windows. Which Windows version are you using?

Best regards,

I am using Windows 10. I don’t see any new device in my device manager during this process though.

Hi @jaski.tx,

We can close this issue now. It was my silly mistake. The way I was shorting the pads were flaky, hence I was struggling.
All good now.

Perfect that you found a solution. Thanks for the feedback.