CE8 SDK incompatible with creating Silverlight/XAML app under WEC 7, VS2008 & CE7 SDK

I am attempting to build a Silverlight/XAML application to run on WEC 7 following the instructions at http://developer.toradex.com/knowledge-base/how-to-create-a-silverlight-application.

I successfully installed all of the pieces, including VS2008 and its updates, Expression Blend 3, Windows Embedded Silverlight Tools and the CE7 SDK.

When I got to the step to create a new VS2008 project with the template Silverlight for Windows Embedded Application, filled in the Name and pressed OK, an error dialog popped up with the message:

Windows Embedded Silverlight Tools,
DataSource file could not be found

After several fruitless hours of troubleshooting, I randomly uninstalled the CE8 SDK. This seems to have fixed the problem and I can now create a Silverlight/XAML project with VS2008 for WEC7.
[I had installed CE8 SDK on previous day while playing with WEC 2013].

It would be nice to have both CE7 and CE8 SDKs installed at the same time as I am evaluating both WEC 7 and WEC 2013.

Thanks sharing this information.

I assume you also found this question on MSDN: https://social.msdn.microsoft.com/Forums/en-US/5ce9d686-373e-48dd-8dfd-511a66fce5c7/bug-in-silverlight-embedded-tools-datasource-file-could-not-be-found?forum=winembnatapp? Did you check if the XML files are there for your installation?

Did you ever try to install first WEC 2013 and then CE 7?

Yes, I saw the MSDN forum article. The most recent comment (from you I assume), gave me the clue to look on the WOW6432Node registry path. The xml file C:\Program Files (x86)\Windows CE Tools\SDKs\Toradex_CE800\Properties.xml existed and looked good. However, the registry path HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows CE Tools\Toradex_CE800 was missing the value name SDKInformation. I added SDKInformation and set the value to C:\Program Files (x86)\Windows CE Tools\SDKs\Toradex_CE800\Properties.xml. I could then create a XAML app for WEC7 in VS2008.

Now I get the DataSource file error when I attempt to create a new WEC2013/XAML project in VS2015. I uninstalled both CE7 and CE8 SDKs and reinstalled CE8 SDK. Still get DataSource error. So now I am completely stuck.

Hello. I have the same problem, using VS2015 Professional, Silverlight 5.0 & Toradex WCE2013 SDK. Registry entries and and files seems to be OK, but cannot create the XAML embedded project.

You have the same error message as @j.s or you don’t find the project template at all? If it is the missing template, please try to use the latest SDK.

I never discovered the cause of my problem. Registry and files looked fine.

I finally uninstalled and then reinstalled VS2015, WEC 2013, Toradex CE8 SDK and related software. It took several hours. I can now build XAML projects for WEC2013. I have not tried WEC7 again.