Can't capture from line-in on Apalis IMX8

I’m following this tutorial to capture from line-in on my Apalis when I enter the first command I’m facing this error:

root@apalis-imx8:~# amixer set 'Capture Mux' 'LINE_IN'
amixer: Unable to find simple control 'Capture Mux',0

this is my cat /proc/asound/cards output that is not the same as tutorial said:

 0 [imxspdif       ]: imx-spdif - imx-spdif
 1 [apalisimx8qmsgt]: apalis-imx8qm-s - apalis-imx8qm-sgtl5000
 2 [imxaudiohdmitx ]: imx-audio-hdmi- - imx-audio-hdmi-tx

Hello It works om our side. Can you try with BSP 5.3?

root@apalis-imx8:~# amixer set ‘Capture Mux’ ‘LINE_IN’
Simple mixer control ‘Capture Mux’,0
Capabilities: enum
Items: ‘MIC_IN’ ‘LINE_IN’
Item0: ‘LINE_IN’
root@apalis-imx8:~# cat /proc/device-tree/toradex,product-id
root@apalis-imx8:~# cat /etc/issue
TDX Wayland with XWayland 5.3.0-devel-20210512+build.301 (dunfell) \n \l

@matthias.tx thanks for your response. I’ve tested it with 5.3 image and it works but it not working on 5.2 image.

Which image did you use?

I’ve tested again with 5.2 multimedia image and it’s work. In my custom image that is based on 5.2 image, problem is from amixer. I solved it with configuring audio input from alsamixer.

Hello farshild,

ok great that works now.

Best Regards,
Matthias Gohlke