Can't access recovery mode on Colibri IMX8X

Hi all,

I recently used the Torizon Easy installer to install a newer version of the Torizon Easy Installer on my Colibri IMX8DX V1.0B Module which is mounted on an Aster Carrier Board. Unfortunately since the installation has been completed, the board stopped reacting completely. There is not output on the connected screen neither is there anything when connection it via UART to a serial console.
I try to use recovery mode to flash the Easy Installer again. However it seems that I can’t even reach recovery mode.

I try to reach it the following way:

1.) Connect USB-Cables to both Micro-USB Ports, shorten the pins as described here (iMX Recovery Mode) and turn the board on keeping the pins shorted for >6 sec. I also tried the same with disconnecting everything and reconnecting again as suggested in the warning.

After that I run the recovery-linux.sh from the downloaded Torizon Easy Installer package. The script is stuck at "Wait for Known USB Device Appear… ". To me that sounds like on a successful entry into recovery mode, the board should be recognized as USB device. However, the only thing that appears is the UART connection
(Future Technology Devices International, Ltd FT232 USB-Serial (UART)).

Is there something I’m doing wrong in my approach? How would I see that I correctly entered recovery mode?

Best regards!

Dear @corinna

Thank you for the detailed information.

the version of the module you are using was an early access product, which we unfortunately do not support any longer.

We recommend to continue using the older version of Toradex Easy Installer. Is there any special reason why you want to switch to a newer version of Toradex Easy Installer?

To avoid these issues, we suggest you to look at the newest version of the Colibri iMX8X available in our store here:

Colibri iMX8X

Best Regards
Kevin

Hi @kevin.tx ,

Thanks for the information!

Actually, updating the Easy Installer was the only option it offered me when I started it. All Linux versions could only be installed with a newer version. Unfortunately, since that installer update my board isn’t responding at all as described above. To flash a proper Easy Installer, I want to get into recovery mode, what I still haven’t managed. Is there anything I’m missing in my approach to set my board into recovery mode?

Best regards
corinna