Cannot flash the image

  • Toradex Bootloader 1.5b2 for Vybrid
  • Build Jul 19 2017 CPU: MVF61 500 Mhz
  • Flash: 512 MB RAM: 256 MB Using ECC
  • Type: 7

The module boots, but I am receiving an error when trying to flash an image (nk7.bin) on it.
The error says: “Cannot find a free block for the image”.

I even tried to use the recovery mode, but doesn’t work.

The last thing I did was using the Update Tool > Update to restore the config.bin (backup of config)

Thank you.

Can you try to access the bootloader console and type

eraseflash configblock

then you can re-flash your image.

I did as you suggested, but now it says, it misses the splash screen, and there was error in restoring the config block. Below is what I tried.

  1. eraseflash configblock
  2. flashloader
  3. flashimage nk7.bin

Does this happen only on a single module or you have multiple ones showing the same behavior?

This happened only on a single one, others are acting normal. But this happened only after I tried to backup config, using the update tool, which created a .bin file. I later used this bin file to restore my config settings, which messed this up. I haven’t tried this again on other modules, since I don’t want them to go bad.

If you can give us a step-by-step description of what you did, including OS image versions that you were running we may try to reproduce the issue here.
If you want you can upload your bin file on and send us a private message with the link.

Unfortunately, I deleted the config.bin file, which I should have preserved for investigation.
But I remember what I did,

  1. Created a backup of config block, using the Update tool. At the time, the module was running bootloader and image v1.3.
  2. Upgraded the module (bootloader and image) to v1.5b2.
  3. Tried to restore the config using the Backup option of Update tool

That’s when it all started.


  1. Is there a way that I can send you a snapshot of what is currently in the memory?
  2. Is there a way that I can completely erase the content, and recover the module, either using recovery mode, etc.

Thank you.

Can you try the procedure we suggested here:
to clear config block?
If you can enter bootloader console you may use eraseflash command to completely clean-up the flash, but then you’ll have to restore BCB, bootloader, static config block etc.