Can not make " repo sync"


I am trying to follow this article

to build the tdx-reference-multimedia-image
unfotunatly when i reached 9/13 percentage in “repo sync” step
I got an error said:

fatal: unable to access ‘’: server certificate verification failed. CAfile: none CRLfile: none

please let me know if this is a repo problem or it is from my side.
because really I’ve tried to open the link and there were no repositories there

please advise.


Dear @rama.aloufee,

Can you please share more information about your issue?

  • What is the Operating System of your machine?
  • Have you tried to do this on another machine?
  • Have you installed repo through this command: curl > ~/bin/repo or through sudo apt install
  • Do you have python or python3 installed on your machine?

I just made a test here and it seems to work on my side without any problems. I’m using Ubuntu 22.04 LTS and the repo installed with curl.

it worked when i installed python3-distutils, also update ca-certificates

sudo apt-get install python3-distutils
sudo apt-get install apt-transport-https ca-certificates -y
sudo update-ca-certificates


1 Like

Glad it’s working now :smiley:

1 Like

I had this happen, and installing python-is-python3 made it work for some reason.

1 Like