Can I load Toradex installer using ssh

Colibri iMX6ULL
Iris v1.1B

I have an old version of Linux running (Linux 4.9.87) which has been stripped down. I cannot get the USB-OTG port to enumerate and there is no HDMI interface.

I can still access the device using ssh.
Is there a way to load the toradex installer via ssh so I can load a new OS. There does not seem to be any references on the toradex or community sites.


Hi @lachlanp , loading toradex easy installer from ssh is not supported. Do you have access to debug console and USB host/SD interface of Colibri iMX6ULL?

In recovery mode:
In recovery mode when I jump JP1 pins 1 & 2 then power up, the USB-OTG interface does not enumerate. Windows recognises that something is happening but there is no USB ID. Also, if I connect a PC to the device via a LAN cable after setting recovery mode, there is no activity on the Ethernet port. Also, no data comes out of the debug port (X13 on the Iris).

In normal mode:
In normal boot mode, the USB OTG interface does not appear to work. It does not enumerate on either Windows or Linux as a serial port. On windows it appears to numerate and the Windows usb controller recognises the USB-OTG port, but I cant determine what it enumerates as, certianly not a serial port. Linux does not recognise anything.

When I log into the device using SSH I can see that it recognises both the SD card and the USB drive and I can read their contents, but when I load the easy installer on either of these, as indicated in :

it still boots from the eMMC. I placed a file in the root directory and that file is there whether I use nothing, SD or USB. I tried both the v1.8 installer and the latest v5.5 installer on both USB and SD cards, but it still only boots into linux on the eMMC. The installer v1.8 I use as supplied, and for installer v5.5 I rename the boot-tezi.scr to boot.scr as is suggested on the above website.

I also tried connecting to the debug port via the IRIS X13. When the device boots there is data coming out but I cannot recognise the data. The documentation says it should be 115200, 8 bit, 1 stop, no parity, and I measure the bit rate and it is correct, but using different computers with that configuration, there is no human readable text from the debug port. If I change the datal ength to 7-bits the data looks more like ascii data but it still has no meaning. I even tried to inverting the data output and that didnt work, and I dont have the ability to read the data in reverse (I.e. LSB first instead of MSB first)

The only way I can get it to work is to allow it to normally boot to eMMC, communicate via the command line via ssh, and manually read the contents of the SD card of USB storage. I cannot get VNC to work in this or any mode.

Any suggestions on how I can move forward to get the installer working
It is a Colibri iMX6ULL 512MB WB IT V1.0A with Iris V1.1B.

I now realise that the debug port uses RS232 instead of TTL. I can now connect to the debug port to enter recovery mode and am able to run the installer and down load a new image

Hi @lachlanp , thanks for your feedback. Good to know it works.