CAN bus on Apalis TK1 seems to not work

We started to work with new OS release which claims to support CAN bus.
But it seems to not work.

We are trying to send something.

ip link set can0 type can bitrate 1000000
ip link set can0 up
cansend can0 -i 0x1F   0x11 0x22 0x33 0x44 0x55 0x55 0x77 0x88


cansend can0 01A#DEADBEEF

And we cannot receive any data using USB-CAN adapter. Also we have tried to receive data using

candump can0

This results in nothing but:

interface = can0, family = 29, type = 3, proto = 1

We have tried several bitrates (125000, 10000 etc.) with same result.

The oscilloscope shows the same picture regardless bitrate and data sent (see below). Channel 1 is CAN-L and channel 2 is CAN-H. The frequency (ca. 30 kHz) is quite strange. The pattern doesn’t change while various data is transmitted.

We’re aware of the issue and are investigating it, I’ll let you know when we have more information.

Is there any progress?

Is there any schedule for updates?

Yes, we just merged NVIDIA’s latest Linux for Tegra aka L4T R21.6 which amongst others drastically improve on the SPI driver. After fine running the CAN driver we should have something ready for you to test very soon.

Hi, we are also interested by this fix. Do you have any news or schedule plan ?

It is included in 2.7b5 release.