C++ Console application not starting in debug after system reboot

I executed a simple C++ command line application.
Everything was ok.
After the weekend (and system reboot) I always get the following error (full log follows).
Can you please give me some direction?
My configuration:

  • Colibri iMX6DL 512MB v1.1Y
  • Iris V2.0A
  • TorizonCore Upstream 5.6.0+build.13 (dunfell)
  • Toradex Torizon Support v1.4.0
Loading application configuration...
Deployment started...
Loading application configuration...
Device is not configured in project properties, prompting user to select a device.
Checking container state...
Container is not up to date, building it (this may take some time)...Step 1/12 : FROM --platform=linux/arm torizon/debian:2-bullseye
 ---> 045ef1b3dc3f
Step 2/12 : EXPOSE 2222
 ---> Using cache
 ---> cddc19eef74c
Step 3/12 : ARG SSHUSERNAME=torizon
 ---> Using cache
 ---> 69addadd23fe
Step 4/12 : ARG SSHUSERNAME=torizon
 ---> Using cache
 ---> 67cb7ee0c1a1
Step 5/12 : ENV DEBIAN_FRONTEND="noninteractive"
 ---> Using cache
 ---> 4367f66808ad
Step 6/12 : RUN touch /usr/bin/g++ &&     chmod +x /usr/bin/g++
 ---> Using cache
 ---> 7e9a0c4c6f14
Step 7/12 : RUN apt-get -q -y update     && apt-get -q -y install     openssl     openssh-server     rsync     libc-dev     gdb     zip     && rm -rf /var/lib/apt/lists/*
 ---> Using cache
 ---> ef9abbeea16e
Step 8/12 : COPY id_rsa.pub /id_rsa.pub
 ---> Using cache
 ---> 574fe2f8d3e5
Step 9/12 : RUN mkdir /var/run/sshd     && sed 's@session\s*required\s*pam_loginuid.so@session optional pam_loginuid.so@g' -i /etc/pam.d/sshd     && if test $SSHUSERNAME != root ; then mkdir -p /home/$SSHUSERNAME/.ssh ; else mkdir -p /root/.ssh ; fi     && if test $SSHUSERNAME != root ; then cp /id_rsa.pub /home/$SSHUSERNAME/.ssh/authorized_keys ; else cp /id_rsa.pub /root/.ssh/authorized_keys ; fi     && echo "PermitUserEnvironment yes" >> /etc/ssh/sshd_config     && echo "Port 2222" >> /etc/ssh/sshd_config     && su -c "env" $SSHUSERNAME > /etc/environment
 ---> Using cache
 ---> 2c7bd3bd7223
Step 10/12 : RUN rm -r /etc/ssh/ssh*key     && dpkg-reconfigure openssh-server
 ---> Using cache
 ---> 9dc084d036e8
Step 11/12 : RUN if [ ! -z "" ]; then     apt-get -q -y update     && apt-get -q -y install      && rm -rf /var/lib/apt/lists/* ;     fi
 ---> Using cache
 ---> d3150b815e77
Step 12/12 : CMD ["/usr/sbin/sshd", "-D"]
 ---> Using cache
 ---> 144d88e19bf2
Successfully built 144d88e19bf2
Successfully tagged cppconsoleexample_arm32v7-debian_bullseye_debug_28101187-f96c-41b8-89fa-e6b4c102b5c8:latest
Deploying and starting remote container (it may take some time after a build or the first time you connect to a device)...Image on target is already up to date.
Stopping current instance...
running startup script...
Starting new instance...
Configuring project...
Successfully removed connection '-56392668;colibri-imx6-10918606 (username=torizon, port=32769, authentication=PrivateKey)'.

Warning: when the connection is not verified, the remote platform is not stored as attribute of the stored connection.
Successfully added connection '209146080;colibri-imx6-10918606 (username=torizon, port=32769, authentication=PrivateKey)'.

The authenticity of host 'colibri-imx6-10918606' can't be established.
ecdsa-sha2-nistp256 key fingerprint is SHA256:NltPbPqUqI4oVQCVe2Jjjf45piTSXebwgAvyUh23sIM.
Warning: accepted key for host 'colibri-imx6-10918606' (ecdsa-sha2-nistp256).
Successfully modified connection '209146080;colibri-imx6-10918606 (username=torizon, port=32769, authentication=PrivateKey)'.

sending incremental file list
created directory /home/torizon//CppConsoleExample
sent 23 bytes  received 67 bytes  60.00 bytes/sec
total size is 0  speedup is 0.00
Error synchronizing folders from SDK container to target application. If you restarted the SDK container (or rebooted your machine) you may need to to a rebuild of the application before deploying and debugging it on the target.
Code: 529
Description: Remote command execution failed.
Message: Remote command rsync -rzv --delete -e "ssh -p 32769 -o \"StrictHostKeyChecking no\"" ~/CppConsoleExample/bin/x64/Debug_debian_arm32v7_bullseye/* torizon@colibri-imx6-10918606:~//CppConsoleExample/ returned error 23

Hi @Lorenzo ,

Could you try rebuilding your SDK container by pressing F1 then typing: Torizon: Rebuild SDK and reload in container?

If the above procedure doesn’t work you can try deleting the application binary/executable (usually a file with the same name as your project name) and all files ending with .o. After that run F1 → Torizon: Build debug container.

Let me know if this solves your problem.

Best regards,
Lucas Akira

Hi Lucas.
I am using the Visual Studio extension (no Visual Studio Code).
Before posting here I tried all sorts of rebuild and nothing worked.
But, as you suggested, by deleting the compilation output folder on my development machine seems to have fixed the problem.

Glad I could help!

Best regards,
Lucas Akira