Buildroot custom image no sound on Apalis iMX6 board

After building a custom image for iMX6Q I have no sound nor hdmi on spdif this is the output of the boot:

[   17.667020] imx-sgtl5000 sound: ASoC: CODEC DAI sgtl5000 not registered
[   17.677492] imx-sgtl5000 sound: snd_soc_register_card failed (-517)

Any suggestion on which module is missing on buildroot?

Kind regards,

Hi @matteo_s

Could you provide the version of the hardware and software of your module?
Concerning your issue, please share the kernel .config and the dmesg.log.

Thanks and best regards,

HW: Toradex Apalis imx6Q 2GB IT V1.1C, Serial# 10492568
SW: Linux buildroot 4.9.166 #1 SMP Fri Jan 24 09:02:52 PST 2020 armv7l GNU/Linux


Hi @matteo_s

Thanks for the dmesg log. You uploaded the uboot config, but I need the linux kernel .config. Could you share this?

If you have done any changes to the devicetree, please share them too.

Best regards,


Here the file. I got it from the buildroot root directory. No modification to the device tree.



Thanks for the file. I don’t see the module SGTL5000 in this file.
Could you boot up the module and provide the config on the module which you get by doing the following command: zcat /proc/config.gz.

Additionally what is output of lsmod on the module?

Best regards,

Sorry for the delay but I got no feed for your ansrwe.
Attached the log.


Here the dmesg log:

[ 3.743581] sgtl5000 2-000a: Error reading chip id -6
[ 3.883314] imx-sgtl5000 sound: ASoC: CODEC DAI sgtl5000 not registered
[ 3.893532] imx-sgtl5000 sound: snd_soc_register_card failed (-517)

HI @matteo_s

Thanks for sharing the files. Your kernel .config seems to be very different for the default .config in Bsp 2.8b6.
Could you exchange the kernel in your image with the kernel with default .config and check if this works for you.

Note: You will need also to deploy the kernel modules too.

For compilation and deployment of the kernel and kernel modules, please have a look here.

Further have you done any change to the device-tree files? If yes, could you share the changes.

Best regards,

I had not modified the device tree. I’ll try asap your suggestions… It seemes an error in sgtl5000.c source of linux related to the device clock.

However I will get in touch soon.



If it could help I have the same error with the image Toradex Easy Installer.

It could be related to the module?

I have the same output with the default .config and also changing the module.

Thanks for the Information. Which carrier board are you using?


It rather looks like a Hardware issue.

Can you install a regular Bsp 2.8b6 and share the complete dmesg.log?

Do you have a different Apalis iMX6? If yes, could you try to use this and check if you see the same error?

Best regards,

I switched the carrier board with another Ixora and the audio works!!!

Perfect that it works. Thanks for your feedback.