Building my own Embedded Linux Image for Apalis-IMX6 with B2QT

Hello,

I’m trying to build my own image for Apalis-IMX6.

I followed all requirements for this, set the MACHINE variable and export to “apalis-imx6”.
I install and set the prerequisites listed on this link - OpenEmbedded (core) - Toradex System/Computer on Modules.

When I run the “bitbake b2qt-embedded-qt5-image”, I got an error that I’m not able to solve it.

Follow the log file that contains the error.

DEBUG: Executing shell function do_compile
NOTE: make -j 8
ERROR: oe_runmake failed
Note: rebuild with "make VERBOSE=1 " to show all compiler parameters.
make[0]: Making `all' in `stubdata'
make[1]: Entering directory '/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/work/x86_64-linux/icu-native/57.1-r0/build/stubdata'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/work/x86_64-linux/icu-native/57.1-r0/build/stubdata'
make[0]: Making `all' in `common'
make[1]: Entering directory '/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/work/x86_64-linux/icu-native/57.1-r0/build/common'
   g++	 ...  ../../icu/source/common/uvector.cpp
   g++	 ...  ../../icu/source/common/uvectr32.cpp
   g++	 ...  ../../icu/source/common/uvectr64.cpp
   g++	 ...  ../../icu/source/common/ustack.cpp
   g++	 ...  ../../icu/source/common/ucnv_io.cpp
   gcc	 ...  ../../icu/source/common/ucnv_cnv.c
   gcc	 ...  ../../icu/source/common/ucnv.c
   g++	 ...  ../../icu/source/common/ucnv_bld.cpp
*** Failed compilation command follows: ----------------------------------------------------------
g++ -isystem/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/sysroots/x86_64-linux/usr/include -D_REENTRANT -DU_HAVE_ELF_H=1 -DU_HAVE_ATOMIC=0 -I../../icu/source/common -DDEFAULT_ICU_PLUGINS="/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/sysroots/x86_64-linux/usr/lib/icu"  -DU_ATTRIBUTE_DEPRECATED= -DU_COMMON_IMPLEMENTATION -isystem/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/sysroots/x86_64-linux/usr/include -O2 -pipe -D_GLIBCXX_USE_CXX11_ABI=0 -std=c++98 -W -Wall -pedantic -Wpointer-arith -Wwrite-strings -Wno-long-long -c -DPIC -fPIC -o uvector.o ../../icu/source/common/uvector.cpp
--- ( rebuild with "make VERBOSE=1 all" to show all parameters ) --------
../../icu/source/config/mh-linux:49: recipe for target 'uvector.o' failed
make[1]: *** [uvector.o] Error 1
make[1]: *** Waiting for unfinished jobs....
   gcc	 ...  ../../icu/source/common/ucnv_cb.c
make[1]: Leaving directory '/home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/work/x86_64-linux/icu-native/57.1-r0/build/common'
Makefile:143: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 2
WARNING: exit code 1 from a shell command.
ERROR: Function failed: do_compile (log file is located at /home/witte/b2qt/meta-boot2qt/build-apalis-imx6/tmp/work/x86_64-linux/icu-native/57.1-r0/temp/log.do_compile.4212)

What am I doing wrong?

I will apreciate for any help, thanks!

You can try to rebuild icu-native:

bitbake -c cleansstate icu-native && bitbake -c icu-native

It solved the error, thanks!