Bootup, Sleep and Wakeup on apalis IMX8QM

Trying to find out 1. bootup time & 2. wakeup time of device after sleep.

Please advise.


Tried echo mem > /sys/power/state for apalis imx8
output : -sh: / sys/power/state permission denied

Is there any other way to put processor in sleep from command line


Hi @ShardulC

Welcome to Toradex community.

Could you provide software and hardware versions of your setup?

Hardware: Apalis imx8QM 4GB WB IT V1.1 on eval board 06805227
Software: Torizon


Hello @ashok.tx Any update about sleep & wakeup functionalities for imx8 board


Hi @ShardulC

Sorry for the delayed response.

  1. bootup time & 2. wakeup time of device after sleep.

systemd-analyze help you to get the boot time statistics.

ok, Thanks @ashok.tx . Using systemd-analyze I get something around 3.8 seconds for kernel and 38.4 for userspace.

Now for putting system in sleep I tried
echo mem > /sys/power/state and the output is -sh: sys/power/state permission denied
is there any work around to put system in sleep and wake it up.

Hi @ShardulC

Could you check with the sudo -i and then echo mem > /sys/power/state.sudo -i allows you to login as a root user.

tried with sudo -i but getting the same output: permission denied…

Hi @ShardulC

It works smoothly in my setup

apalis-imx8-06548495 login: torizon
apalis-imx8-06548495:~$ sudo -i
root@apalis-imx8-06548495:~# echo mem > /sys/power/state