Booting with TFTP / NFS ends with Kernel panic


When trying to boot the process ends with [ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)].
On my Linux-developer-box I start Mincom to connect to the serial port of my Ixora-Board.
On my Linux-Box there are a DHCP-, a TFTP and a NFS-Server.
On the attached file you can see the output of the Minicom.

Link to Minicom Output

Any ideas about a possible reason?

Best Regards ah4711

@ah4711, /etc/exports on you NFS server should specify which NFS roots to export. nfsroot= of your Apalis should be not empty like is seen in your boot log, but point to specific exported root, something like


,v3 specifies NFS version. For some reason it doesn’t work me with Ubuntu without “v3”.

The Ubuntu configuration files are as follows:

  1. /etc/dhcp/dhcpd.conf

    option domain-name “”;
    option domain-name-servers,;

    default-lease-time 600;
    max-lease-time 7200;

    ddns-update-style none;

    log-facility local7;

    subnet netmask {
    option domain-name-servers;
    option domain-name “”;
    option subnet-mask;
    option routers;
    option broadcast-address;
    default-lease-time 86400;
    option ip-forwarding off;
    max-lease-time 86400;
    interface enp0s31f6;

    host eval {
    filename “uImage”;
    hardware ethernet 38:22:e2:ef:75:2d;
    option host-name “apalis”;
    option root-path “,wsize=1024,rsize=1024,v3”;

  2. /etc/exports

    I entered as U-Boot var:

    Then I started with

    run bootcmd_dhcp
    But the result was the same

Actually I never fed our DHCP server with parameters to boot Colibri. Two or more DHCP servers on the same network is bad idea. Separate network, which is unable to talk to my development PC is wrong idea either. Additional network card for additional Colibri network? I don’t like it as well.

I’m booting from NFS/TFTP just editing default u-boot variables. Something like:

setenv serverip
setenv nfsargs ip= root=/dev/nfs rw nfsroot=${serverip}:/home/edward/toradex-i7/rfs,v3
setenv nfsboot 'run setup && setenv bootargs ${defargs} ${nfsargs} ${setupargs} ${vidargs} && echo Booting from NFS... && ubi part ubi && run m4boot && tftp ${kernel_addr_r} ${board}/${kernel_file} && tftp ${fdt_addr_r} ${board}/${soc}-colibri${variant}-${fdt_board}.dtb && run fdt_fixup && bootz ${kernel_addr_r} - ${fdt_addr_r}'

Just right nfsargs for kernel command line, tftp to load dtb and zImage and bootz. No need to alter company or department DHCP server.

Hi @ah4711

Are you having this Setup for your network?

Best regards,

Yes exactly, that was my guideline.
My Linux-Box runs with Ubuntu 18.04.
My developer net is not connected to the internet.

The problem is solved.
In the file /etc/dhcp/dhcpd.conf

hardware ethernet 38:22:e2:ef:75:2d;

was wrong.

Perfect that your issue is solved. Thanks for the feedback.