Boot2Qt Toolchain for Windows


I want to build an SDK for Windows with the Boot2Qt Yocto image. The commands I use for that are like this:

$ export SDKMACHINE=i686-mingw32
$ bitbake meta-toolchain-b2qt-embedded-qt5-sdk

However, I got an error like the following:

ERROR: meta-toolchain-b2qt-embedded-qt5-sdk-1.0-r0 do_populate_sdk: The postinstall intercept hook 'update_gtk_icon_cache' failed, details in /home/pc_742/B2QT/build-apalis-imx6/tmp/work/cortexa9t2hf-neon-poky-linux-gnueabi/meta-toolchain-b2qt-embedded-qt5-sdk/1.0-r0/temp/log.do_populate_sdk
ERROR: Logfile of failure stored in: /home/pc_742/B2QT/build-apalis-imx6/tmp/work/cortexa9t2hf-neon-poky-linux-gnueabi/meta-toolchain-b2qt-embedded-qt5-sdk/1.0-r0/temp/log.do_populate_sdk.26094
ERROR: Task (/home/pc_742/B2QT/sources/meta-boot2qt/meta-boot2qt-distro/recipes-qt/meta/ failed with exit code '1'

I’m using the Boot2Qt Zeus branch, version 3.0.4.

I reverted the changes I made and built from scratch. I still get the same error.
I also re-fetched the source files, but the error did not resolve.

Hello @muratc98 ,

From the yocto thread here it looks like this issue is solved by adding “qemuwrapper-cross” to the depends of your

I hope this helps. But as you have a commercial version of Qt, you could also contact our partner Qt company directly for your queries.

BR, Janani