Boot Toradex Easy Installer via TFTP with old U-Boot 2015.04

In the question <Prepare Image of Toradex Easy Installer to boot from TFTP> there was a actual Version of U-Boot used. Booting is successful.

Unfortunately our already installed Images have U-Boot Version 2015.04.
This U-Boot doesn’t know the command run bootcmd_dhcp. Is there a possibility to do the same with the “old” U-Boot commands and the actual Image of the “Toradex Easy Installer”?

Dear @ah4711,

Thanks for using the community.

We are looking into your question.


Dear @ah4711 ,

did you try the code segment in the link you provided?

According to our information this code segment should work under 2015.04 as well.

setenv bootargs console=ttymxc0,115200 quiet video=DPI-1:640x480D video=HDMI-A-1:640x480-16@60D video=LVDS-1:d video=VGA-1:640x480-16@60D rootfstype=squashfs root=/dev/ram autoinstall ${teziargs}
 # Reenable fdt relocation since in place fdt edits corrupt the ramdisk
 # in a FIT image...
 setenv fdt_high
 # Load FIT image from location as detected by distroboot
 tftp ${ramdisk_addr_r} ${prefix}tezi.itb
 bootm ${ramdisk_addr_r}

Let us know about the progress.

Best Regards

The try was not successful.

On th screenshot of minicom you can see, that a wrong file is expected to be loaded. Because this file is not existent in the image of the “Toradex Easy Installer”, we have a loading timeout…


it seems like the attaching of the screenshot failed. I am unable to see it. Could you try again?


Here again my screenshot

Hi @ah4711 ,

it is possible that there are mismatches in the device tree file, or missing arguments like the value for “${teziargs}”.

Would it be possible to get your device tree file for further analysis?

Furthermore, I would like to ask, is there a specific reason why you want to use a 2015 version of U-boot?

Best Regards

As I have already written in the question mentioned above on the first line, we have a running system (with U-Boot 2015.4) which we would like to upgrade.

We have a really deep embedded Apalis/Carrier-Board. The only available connections are the serial and the Lan port. All USB-ports are not reachable. This layout was made to use the “legacy flashing method”. In these days we didn’t know, that this flashing method will become “legacy”. Now we should flash a new Image. Of course we would prefere to use the actuel Yocto/Toradex/Boot2Qt-Image. Our idee now is to create a “state of the art” Image in the TEZI-format and load it with your ToradexEasyInstaller. The problem now is to start this ToradexEasyInstaller. We already have a Custom-Image on the Apalis. Because we can NOT load this ToradexEasyInstaller via USB-OTG we try it by “Booting from TFTP / NFS”. As soon as we have ToradexEasyInstaller running we can flash what we want.

With a actual U-Boot version I could boot this ToradexEasyInstaller, but not yet with one of our old images with U-Boot version 2015.04.

The device tree file is not visible on the TFTP-server. I think there is all included in the tezi.itb.

Dear @ah4711,

thanks for the explanation. Now I understand the issue.

So since currently you run U-Boot 2015.04, I am expecting that you are running BSP 2.6 on your device. You correctly identified that with the version your running now, there is no Toradex Easy Installer available.

First step would be to use the “legacy” method to update to BSP 2.8.

From there you will be able to install ToradexEasyInstaller 1.8 which you will find here:

Toradex Easy Installer 1.8

With Toradex Easy Installer 1.8 installed, you can use that to install the newest nightly build which is version 5.3. The huge jump in version number, is our way of aligning all software to the same version number.

Toradex Easy Installer nightly

If you are able to do that, from here it should be possible to update to any image you like.

Please let me know if you had success following these steps.

Best Regards

After installing the image “Apalis-iMX6_LXDE-Image_2.8b7.-20200610.tar.bz2” I run the same procudure as above. Now the U-Boot version is 2016.11.

Again the file was not found. See screenshot below:

Dear @ah4711,

Thanks for the update.

What version of Toradex Easy Installer did you flash onto your module?

Did you proceed to install the newest version of Toradex Easy Installer, so that you can flash the newest image onto your module?


No, I tried to follow up the whole update process from the beginning with our good old image with U-Boot 2015.04 installed on the target.

Then update to image BSP 2.8 with legacy style. There I found U-Boot 2016.11.

Then I tried to boot from there the “Toradex Easy Installer” 1.8. This booting with TFTP-server failed. Above you can see the according output.

From here on I need help.

That was it. Thank you. Now I succeeded to boot the Toradex Easy Installer out of U-Boot version 2016.11.
The solution was, that I had to enter the U-Boot Args direct in the U-Boot-Terminal and not expect that the Args will be read from the file “boot.scr” on the TFTP-Server.

Hi @ah4711,

Thanks for letting us know.

Glad that this solution worked.

I will close the ticket.

Best Regards

Dear @ah4711,

thank you for your patience.

Since you already successfully installed BSP 2.8 and are able to get into U-Boot. I suggest trying the following.

  • To run the Toradex Easy Installer 1.8, the file “tezi.itb” needs to be placed on your TFTP server.
  • After that in U-boot you need to set the correct serverip as well as your own. (Which I guess you already did)
  • Additionally to boot you need to specify the boot arguments for the device. You achieve this by entering the following into u-boot. (These can be found in the first line of the “boot.scr” file that you can see in the Toradex Easy Installer directory)
  • BOOT ARGUMENTS: setenv bootargs console=ttymxc0,115200 quiet video=mxcfb0:dev=hdmi,640x480@60,if=RGB24 video=mxcfb1:dev=lcd,640x480@60,if=RGB24 video=mxcfb2:dev=vdac,640x480@60,if=RGB565 video=mxcfb3:off rootfstype=squashfs root=/dev/ram autoinstall ${teziargs}
  • After that, you need to set setenv fdt_high
  • If you completed the steps above, boot by loading the Toradex Easy Installer into the right part of the ram. You achieve this by entering tftp ${ramdisk_addr_r} You should now see the file being transferred to your device.
  • To finally boot it, the command bootm ${ramdisk_addr_r} is necessary.
  • From here Toradex Easy Installer 1.8 should boot and as soon as this has been done, you can upgrade to the newer versions of Toradex Easy Installer and from there you can upgrade to any version you want.

I reproduced this exact procedure and it worked on my side.

I hope this helps, please let me know about your progress.

Best Regards