Bluetooth issues on Intel 6230 N

Welcome everyone,

Long story short: we have problem to launch bluetooth on Intel Centrino 6230 N mini-PCI module. Wifi works.

# lspci
00:00.0 PCI bridge: Synopsys, Inc. DWC_usb3 / PCIe bridge (rev 01)
01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
# lsusb
Bus 001 Device 003: ID 8086:0189 Intel Corp.

This is on Linux apalis-imx6 5.4.193-5.7.4-devel+git.61d265bd311b #1 SMP Tue Nov 14 12:41:56 UTC 2023 armv7l armv7l armv7l GNU/Linux

I took kernel configuration from 5.4 backports - and just added to our defconfig:

# lsmod
Module                  Size  Used by
usb_f_rndis            32768  2
u_ether                24576  1 usb_f_rndis
bnep                   24576  2
mxc_v4l2_capture       61440  0
ipu_bg_overlay_sdc     16384  1 mxc_v4l2_capture
ipu_still              16384  1 mxc_v4l2_capture
v4l2_int_device        16384  1 mxc_v4l2_capture
ipu_prp_enc            16384  1 mxc_v4l2_capture
ipu_csi_enc            16384  1 mxc_v4l2_capture
ipu_fg_overlay_sdc     16384  1 mxc_v4l2_capture
iwldvm                192512  0
mac80211              487424  1 iwldvm
btusb                  45056  0
btintel                20480  1 btusb
bluetooth             491520  12 btintel,bnep,btusb
hid_multitouch         24576  0
iwlwifi               266240  1 iwldvm
imx_sdma               36864  6
virt_dma               16384  1 imx_sdma
cfg80211              335872  3 iwlwifi,mac80211,iwldvm
secvio                 16384  0
flexcan                32768  0
can_dev                28672  1 flexcan
libcomposite           61440  10 usb_f_rndis
configfs               45056  3 usb_f_rndis,libcomposite
galcore               405504  7

WiFi works but Bluetooth doesn’t. I cannot rise it up:

# hciconfig hci0 up
Can't init device hci0: Invalid request code (56)
# dmesg
 Bluetooth: hci0: unexpected event for opcode 0x0000
 debugfs: File 'dut_mode' in directory 'hci0' already present!

So bluetoothctl doesn’t work.
But I tried to plug some Bluetooth USB dongle and I was able use BT, so the rest of the system is capable for bluetooth.

Please, help me figure out what is missing in this puzzle.

Hi @SeeLook,

Thanks for writing to Toradex community!

Regarding your query unfortunately we do not have this chip to test so it would be bit difficult to suggest what went wrong. That said we did some search online and found device earlier to 7260 are not tested well with Wifi/Bluetooth coexistence. May be this is what you are facing issue.

Please take a look at below link and try to check the solution mentioned at bottom of the page
en:users:drivers:iwlwifi [Linux Wireless]

Best Regards
Ritesh Kumar

Thank You for the answer.

Somehow it gives me a clue what I might try more.
For Dunfell I will try to use backports for 5.4 kernel but also we are migrating to Kirkstone, so maybe Linux 6.1 will bring solution itself.

Because, meanwhile I tried configure 5.4 kernel with menuconfig (previously I was adding CONFIG_ to defconf manually) and the result is exactly the same.
So it is quite possible there is some bug.