Blank screen

We are trying to use iMX6S with resistive touch display, 4.3 inch TFT-LCD, 480x272. Splash screen is shown correctly, but when it comes to windows, we see only white screen (back light works).

Same hardware works with VF50 and T20 with WEC7, It also works with same iMX6S module with Linux.

A while back we tested same configuration on old (two years) iMX6S module. I think it came with WEC7 pre-installed and it worked.
That module got “fried” so we bought two new ones, that we can not configure to work.
We tried WEC7 BSP 1.6, 1.5 and 1.2.
Same problem occurs if we set SplashScreen registers or windows registers or your Display tool.

We also came upon perhaps related problem - UseSplashSettings register has no effect. If I understand correctly this register should override windows settings with ones from SplashScreen (at least it does so on VF50).
With Remote Display tool we can see that resolution changes if we reconfigure windows registers and this happens with UseSplashSettings enabled.

Dear @piseek,

Thank you for contacting the Toradex community with detailed issue reports.

Could you share the display datasheet?

Could you dump splash screen and display registry configuration and share it with us.

Can you confirm the display pins alternate functionality is configured correctly by using the gpio tool? Maybe PCLK or PCP or OEP or HSP or VSP or DISP_GPIO or HSYNC pin, VSYNC pin not configured properly or bug in the software.

Do you have only one iMX6S? If you have multiple IMX6S could you try with other modules?

If none of the above don’t help then please share the modules serial number and let me quickly check the production logs of the modules.

We have same problem with two different iMX6S modules. Hardware is ok, for it works fine with T20 and VF50.

Attached is the display datasheet, registry and ss config.

I have checked pin configuration. All display pins have alternate functions set too default, as described in iMX6 datasheet. That is IPU, should they be set to LCD? Attached is screenshot of HSYNC and VSYNC pin configuration.


Dear @piseek,

Could you share the display datasheet, it is missing in the above links.

Also, it seems default splash screen config is programmed and you didn’t touch the splash screen section.

Link to datasheet should work now.

The default configuration of splash screen config works. I can see the splash screen. It also works with appropriate resolution here.
When it comes to windows I see only white screen.

Dear @piseek,

Sorry, I forgot to ask, Could you also share the schematic of the display section.

Here are the schematics.

Dear @piseek,

Could you run the Gpio tool and verify the functionality of the following pins. I am highly suspecting LCD_PON signal, Could you turn GPIO and set to an enabled state. HSYNC, VSYNC, DE signals should be IPU1 functionality.

Display – Signal Name – SODIMM pin
30 LCD_PCLK 56
31 LCD_PON 90

Set below splash screen configuration

  • ss.pclk: 9000000 (PixelClock (in Hz))
  • ss.hsw: 0 (Horizontal Sync Width)
  • ss.blw: 40 (Begin of Line Width)
  • ss.elw: 5 (End of Line Width)
  • ss.vsw: 0 (Vertical Sync Width)
  • ss.bfw: 8 (Begin of Frame Width)
  • ss.efw: 8 (End of Frame Width)
  • ss.width: 480 (Display Width)
  • ss.height: 272 (Display Height)
  • ss.disp_gpio: 90 (Display On/Off SO-DIMM/MXM3 pin (0 means no pin used for this purpose))

Set below registry, you don’t need to touch any other registry


Still, if you see the issue then probe PCLK, PON, HSYNC, VSYNC, DATA_ENABLE signals and let us know the results.

You are right, it was LCD_PON pin. Setting “ss.disp_gpio: 90” did the trick.

Still its strange to me, how it works for VF50, with “ss.disp_gpio: 0”, were GPIO tool shows this pin as input.

Thank you very much!

Dear @piseek,

Glad to know you fix the problem. Maybe the default state of SODIMM 90 is enabled for the LCD on other SOMs.