Blank Screen after OS Install - Colibri iMX8

I am attempting to connect and setup the 7" Touch Display from Toradex with the Colibri eval board and Colibri iMX8X.

I started off following through the “Getting Started” tutorial for the iMX8X running Torizon with a Windows host. I have the eval board connected to a Dell display via VGA. The easy installer was displayed and I chose the Torizon with eval containers for hardware V1.0C option. There was not a V1.0D version to match the sticker on my CoM.

After the OS was installed the device restarted and nothing was displayed on the VGA Monitor. I was able to monitor the serial output and connect via ssh over the network. Using the SSH connection I was able to complete the “Getting Started” tutorial.

Now I want to view the UI and test the touch display, however I am not seeing anything being outputted. I have the 7" display connected via the FFC and the Capacitive Touch Adapter. I used the Touch Adapter’s datasheet to wire it to the eval board.

I have read through the following pages, but I have not found the details I need to solve this.
https://developer.toradex.com/knowledge-base/first-steps-with-capacitive-touch-display-7-inch-parallel
https://developer.toradex.com/knowledge-base/display-output-resolution-and-timings-linux

From these pages it seems like the Parallel display output should be the default setting and should work. I currently have both the 7" display and the VGA display connected to the eval board and nothing is being displayed. Any ideas or suggestions on what my next steps should be to resolve this issue?

Thanks.

Greetings @malley,

If you installed the a 5.0 image there was a change wherein parallel RGB is disabled by default. Which would explain why you’re suddenly seeing no display output at all. Fortunately it should be a relatively easy matter to re-enable the interface as well as configure the output for our 7’’ display.

On our Linux images you can make use of device tree overlays to make hardware changes without needing to recompile the entire kernel. More info on that here: https://developer.toradex.com/knowledge-base/device-tree-overlays

For Toradex displays we already have premade overlays created so you should just need to apply them and not create anything yourself. The page I linked also has a table at the bottom that shows what overlays need to be applied to get a certain Toradex display working.

Best Regards,
Jeremias

Ok I was able to update the device tree with the 3 suggested overlays using the following command.

torizoncore-builder dt overlay --devicetree imx8qxp-colibri-eval-v3.dtb device-trees/overlays/colibri-imx8x_parallel-rgb_overlay.dts device-trees/overlays/display-lt161010_overlay.dts device-trees/overlays/colibri-imx8x_atmel-mxt_overlay.dts

I then made the union and deployed to the target. I was able to get the display to turn and show the portainer login screen. However, the touch input is not working.

On boot up I get the following serial output. This leads me to believe there are some i2c issues connecting to the touch screen. I have checked the wiring several times against the eval board, display, and adapter schematics. Any other ideas?

Hmm I wasn’t able to recreate this on my setup. Can you additionally provide the output of dmesg | grep -i atmel.

Also just to make sure you tried touch on the portainer UI and it wasn’t working? I ask cause sometimes the i.MX8X can throw such I2C errors but touch works despite the error messages.

Other than that, I wasn’t able to recreate your environment exactly since I don’t have a capacitive touch adapter with me presently. Therefore I was using a carrier board with a native touch connector rather than an adapter. With that being said I’m inclined to believe that the overlays themselves should be fine.

I guess you could show/describe your hardware connections to me so I can double-check. Also I’ve had past experiences where I actually had the flat flex cable in the wrong way on the adapter and had to just simply flip it, might want to try just as a quick sanity check.

Best Regards,
Jeremias

Well this is not going as planned. I tried flipping the flex cable and the results did not change. I reconnected the adapter board per the instruction in the datasheet for the calibri board. Still no results.

After several restarts I now no longer have Ethernet or USB (mouse/keyboard) connectivity. I am getting new errors outputting to the serial output.

I tried the recovery mode, but the ethernet and keyboard no longer connect and I am unable to select anything in the the Easy Installer.

UPDATE*
So I tried a few combinations with the other hardware I purchased and it looks like there may be an issue with one of my eval boards and with one of my iMX8 boards.

Eval_1 + iMX8_1 = no USB + no ethernet
Eval_1 + iMX8_2 = no USB + ethernet
Eval_1 + iMX6ULL_1 = no USB + ethernet

Eval_2 + iMX8_1 = USB + no ethernet
Eval_2 + iMX8_2 = USB + ethernet
Eval_2 + iMX6ULL_1 = USB + ethernet

It looks like Eval_1 board has an issue with USB and iMX8_1 has an issue with ethernet. Eval_1 + iMX8_1 were the boards I was using that were working up until I flipped the flex PCB for the touch input.

Either the ethernet on the iMX8 is dead or it is improperly configured. Are there details on how to load a new image via the easy installer through a USB drive or SD card?

Well then your new issues as well as the update has me very interested in what’s going on with the hardware you have.

But yeah let’s try a recovery + reinstall before we jump to a possible RMA for the problematic hardware.

As I understand you’re able to load easy installer correct? You just can’t install anything cause the Ethernet is unstable. In that case you can put an Easy Installer package on a USB/SD media and install off of that. More details here: https://developer.toradex.com/software/toradex-easy-installer#providing-the-images

Though in short you just need to download a compatible i.MX8 Easy Installer package zip file from us and then unzip it onto the USB/SD media.

Best Regards,
Jeremias

I was able to reinstall the image I had been using, torizon-core-docker-evaluation-colibri-imx8x-Tezi_5.1.0-devel-202011+build.4.container.

I still only have access to the system via the serial console. The device is still failing to initialize the ethernet.

The only difference I can see from the boot up output between the device that works and the device that does not is the following message:

fec 5B040000.ethernet ethernet0: unable to connect to phy

I am not sure what the next steps are.

I assume this is with iMX8_1, the module with the Ethernet issue as you described earlier?

Well since you reflashed the software completely I’d say that eliminates software as a potential cause. I’m not sure how or why but it seems likely that for some reason that specific i.MX8 module has a hardware issue that is affecting Ethernet.

You can either submit an RMA for that hardware. Or I can also check with our hardware guys and see if there’s any measurements or checks you can make to see if it is indeed a hardware fault. Either way you eventually have to RMA since there’s probably no repairs that can be done on your side if it’s hardware related.

But please double check with your other IMX8 just to confirm that this Ethernet issue is localized to a specific module. By double-checking I mean flashing and running the same software as you just flashed on the first IMX8.

Best Regards,
Jeremias