Black screen and mouse pointer after awakening suspended screen

Good afternoon

We are trying to enable power saving on a monitor connected (via hdmi) to the Apalis tk1 when the device is not in use.
With lxdm enabled to try this we have used the instruction (entered via serial terminal):

xset dpms force suspend

After the instruction the screen is correctly put in suspended mode. When i move the mouse the screen awakens but i’m not seeing what was visible before i entered the instruction. I can only see a black screen and the mouse pointer which i can move. I expected to see again the lxde desktop. In order to make lxde available again i have to stop and restart lxdm (systemctl stop lxdm, systemctl start lxdm)

I’ve also tried other instructions like

xset dpms force off
xset dpms force standby

but got the same result
Also tried not forcing it but enabling dpms with xset dpms 5 10 15 and the same thing happens when waking up the screen.
I tried using xset s blank; xset s 5; but this only makes the screen black and not enter power saving mode

My objective is to be able to use this not with the lxde desktop but with a script that starts openbox and an app/browser

Thanks in advance

Hi @neonism

You could turn off and on the Output like this:

  1. xrandr --output HDMI-0 --off
  2. xrandr --output HDMI-0 --auto

Best regards, Jaski

Thanks for the response. Managed to use those instructions and it works ok


You are welcome. Thanks for the feedback. Did you achieve to automate it?