BITBLT slow WEC7 1.5b4


we have already discussed (and finally solved) the problem of bitblt being slow:

Now I have updated to 1.5b4 and I again get this problem. BitBlt for full hd resolution takes about 300ms (see attached screen shot).

This screenshot was done with your image 1.5b4, registry only modified to increase screen resolution. ipumem increased with configblockeditor.

I also upload my blttest project.

Are you sure that all modifications done last year have found their way into 1.5b4 ?
Or is something wrong on my side ?

Thank you

What is your current BPP setting?

I have now set BPP to 32, saved registry, rebooted. The result is the same: bltbit takes about/near 300ms


for further investigation I went back to Toradex image 1.4 (stable release). Unfortunately even with 1.4 I got long times. The trials last year in July were done with a beta version of 1.4 and with some files (ipuvflat3.dll and eboot.spl) that were sent to me.

I would appreciate if at least somebody could test with my blttest.exe the behaviour of 2d acceleation (to exclude that there is something wrong on my side).

As told above I tested original Toradex image and bootloader 1.5b4, registry modified for full HD, BPP 32, in config block ipumem set to 67108864

Thank you !

Sorry, for slow reply, we are investigating the issue to figure out why the regression happened. I hope to have some new in coming weeks.

Thank you for reply.

At the moment it is sufficient for me to know that you are working on it.

Kind regards


can we hope that this issue is addressed in release 1.5 ?

Thank you !

Dear @Frax222
We still plan to bring the fix into the final V1.5 release. However, it is getting tight, so I cannot guarantee that we can hold this schedule.
Regards, Andy

I am testing this with the same application you sent me and I got 34-35ms at full-HD resolution (1920x1080 @ 32bpp).
I took the 1.5b4 standard image, used display tool to apply 1080p settings (both registry and configblock) and rebooted.
And your app seems to work as expected.
Can you please do the same test and, if your results don’t match, send me the output you get on serial port after you do:
set dbg.serial 1
save dbg
on the serial bootloader console?

Hello Valter,

now it works, I now used display tool to set 1080p settings and stored both into registry and config block (before I stored settings in registry only).

But the main thing seems to be ipumem. As discussed last year I have to set this to 67108864.
Unfortunately I did not do this in bootloader but with configblockeditor 1.11 where ipumem and gpumem seem to be interchanged. So I increased gpumem instead of ipumem.

Anyway thank you for your help.

Thank you for the update.