Bitbake Error

I am trying to build linux image using BSP 2.8b6
I am following the procedure given in OpenEmbedded (core) - Toradex System/Computer on Modules

repo sync has done.

Now i need to add opencv packages for opencv 3.3 in local.conf or in any other
What could be the suitable one to append.
Please provide the procedure for appending opencv 3.3 packages while building this.

By the way i have appended some packages,

ACCEPT_FSL_EULA = "1"
IMAGE_INSTALL_append = " opencv opencv-samples"
IMAGE_INSTALL_append = " opencv libgomp"

Then i run the command to bitbake: hemashre@hemashre-HP:~/yocto/build$ bitbake -k angstrom-lxde-image

The following error has occurred.

hemashre@hemashre-HP:~/yocto/build$ bitbake -k angstrom-lxde-image WARNING: /home/hemashre/yocto/build/../layers/meta-jetson-tk1/recipes-kernel/linux/linux-L4T_3.10.bb: QA Issue: PN: linux-L4T is upper case, this can result in unexpected behavior. [uppercase-pn] Parsing recipes: 100% |##########################################################################################################| Time: 0:03:30 Parsing of 3025 .bb files complete (0 cached, 3025 parsed). 3891 targets, 187 skipped, 0 masked, 0 errors. WARNING: No recipes available for:   /home/hemashre/yocto/build/../layers/meta-freescale/dynamic-layers/browser-layer/recipes-browser/chromium/chromium-wayland_48.0.2548.0.bbappend /home/hemashre/yocto/build/../layers/meta-freescale/dynamic-layers/browser-layer/recipes-browser/chromium/chromium_52.0.2743.76.bbappend /home/hemashre/yocto/build/../layers/meta-jetson-tk1/recipes-graphics/mesa/mesa_11.1.1.bbappend NOTE: Resolving any missing task queue dependencies ***ERROR: Nothing RPROVIDES 'opencv-samples' (but /home/hemashre/yocto/build/../layers/meta-toradex-demos/recipes-images/images/angstrom-lxde-image.bb RDEPENDS on or otherwise requires it)*** NOTE: Runtime target 'opencv-samples' is unbuildable, removing... Missing or unbuildable dependency chain was: ['opencv-samples'] ERROR: Nothing RPROVIDES 'angstrom-lxde-image' No eligible RPROVIDERs exist for 'angstrom-lxde-image' NOTE: Runtime target 'angstrom-lxde-image' is unbuildable, removing... Missing or unbuildable dependency chain was: ['angstrom-lxde-image']

Build Configuration: BB_VERSION     
= "1.36.0" BUILD_SYS            = "x86_64-linux" NATIVELSBSTRING     
= "ubuntu-14.04" TARGET_SYS           = "arm-angstrom-linux-gnueabi" MACHINE              = "apalis-imx6" DISTRO               = "angstrom" DISTRO_VERSION       = "v2017.12" TUNE_FEATURES        = "arm armv7a vfp thumb neon callconvention-hard" TARGET_FPU           = "hard" meta-angstrom        = "HEAD:4318892e08ea9102d29bdd92af83539bea985e4b" meta-toradex-nxp     = "HEAD:a5f5d85e52717e136e692478fb5d822c1ce70046" meta-freescale       = "HEAD:61ab34ac6d664a229847b796ec20fd9f7c8ecbf4" meta-freescale-3rdparty = "HEAD:e71ace9ede9b58f2ed3381a53fdc814f8e963c60" meta-toradex-tegra   = "HEAD:c10c7168712fa47e50440a7b7b012118939a3371" meta-jetson-tk1      = "HEAD:e8b87fe8da7c6fcffa37ab245f50082953cc1ee1" meta-toradex-bsp-common = "HEAD:78e1cdabe0baeb794945bd4926c28058f9f12aa9" meta-oe               meta-filesystems      meta-gnome     meta-xfce             meta-initramfs meta-networking       meta-multimedia       meta-python   
= "HEAD:eae996301d9c097bcbeb8046f08041dc82bb62f8" meta-lxde            = "HEAD:f436137fcc4ac700dc5c1b5e31e5b3c27568fc3e" meta-browser         = "HEAD:75640e14e325479c076b6272b646be7a239c18aa" meta-qt4             = "HEAD:e290738759ef3f39c9e079eaa9b606a62107e5ba" meta-qt5             = "HEAD:d8b531530fa42b59aa0a5b123d87a30d749cbcc4" meta-qt5-extra       = "HEAD:79e26686520f2ce5f743975e90116b263a33697f" meta-freescale-distro = "HEAD:51756d1c2058139c8a21f89b86cfd8007b71b7f0" meta-toradex-demos   = "HEAD:014344d116f7c17c10be35d0d2a66a0038df6c75" meta                 = "HEAD:3638cb32ba9ba32b4d498fc31ab7fdf82f0d2495"

ERROR: All buildable tasks have been run but the build is incomplete (--continue mode). Errors for the tasks that failed will have been printed above. ERROR: Command execution failed: 1

Summary: There were 2 WARNING messages shown. Summary: There were 4 ERROR messages shown, returning a non-zero exit code.

Please provide some solution for this.

Hi @hemasree

Which Host Linux Distribution are you using?
Did you install all the Prerequisites?

Did you get any errors during repo sync?
Could you provide the output of repo sync in a text file?

Best regards,
Jaski

Ubuntu 14.04
yes
no
After repo sync build and layers directory had created.

Could you share the local.conf file?

Ubuntu 14.04

Is this 32-bit or 64-bit machine?

opencv-samples

According to this, you should just append opencv and not additionally opencv-samples?

Best regards,
Jaski