Bitbake error with LinuxImagev2.8

Trying to bitbake an image for Colibri iMX6 v2.8
Host: Ubuntu 16.04 LTS
bitbake -k console-tdx-image
Tried with and without the “backports” (I don’t need Wifi drivers) without success.

My goal is to get an image with the real time patch. You will see the last two lines of the local.conf commented out. Let me know if the build will go thru if I remove the comments. But right now I can’t get the basic image build to go thru.

Please see attachments for the error messages and the local.conf filelink text


Does it help if you move the definition of MACHINE above the first user of that variable, i.e. swap the following two lines in local.conf:

include conf/machine/include/${MACHINE}.inc

MACHINE ?= "colibri-imx6"


You have to cherry-pick this commit in meta-toradex-nxp if you want the RT kernel.

Moving MACHINE ?= “colibri-imx6” line up helped making the standard image.

Added the last two lines for the real time patch (see local.conf) and tried bit baking the image again but this time it failed. See attached files
link text