Bitbake error while following the instructions on Toradex guideline

I had created an image without error before using following guideline provided by Toradex.
After I formatted my computer.
Following error started to appear.

ERROR: ParseError at /home/spear/oe-core/build/../layers/meta-toradex-bsp-common/recipes-kernel/linux-firmware/ Could not include required file recipes-kernel/linux-firmware/
ERROR: Parsing halted due to errors, see error messages above

The only change I have made on local.conf file is as follows

MACHINE ?= "colibri-imx6"

I have the same problem. It seems that in the recipe “”, there is a require condition to “recipes-kernel/linux-firmware/” that in this distribution it is not present. I hope that someone gives us some light on how to proceed.

In this link it is described something similar:


Hi @oceanblue and @aarribas !

Could you please refer to this other thread?

As you can see there, please try to update your repo manifest to solve the issue.

Please let us know if this helps you :slight_smile:

Best regards,

Hi @henrique.tx
If I understand well, the proposition is to remove the recipe ‘recipes-kernel/linux-firmware/’.
So if it is, I have remove it and the bitbake started to compile. But at the end the uboot is generated, but not the full image. The error is shown in the attached image.
Any idea is appreciated.
Best Regards,

Hi @aarribas !

Actually, the main idea from that thread is that this issue is already solved by this commit: meta-toradex-bsp-common.git - Toradex BSP layer, recipes common to all modules

So updating the manifest version you are using (therefore the layers as well) should solve the issue.

To learn how to update the layers, please refer to the Update Existing Configuration section of the Build a Reference Image with Yocto Project/OpenEmbedded | Toradex Developer Center article.

Best regards,

Hi @aarribas!

By the way, from the error you shared, you are missing the ACCEPT_FSL_EULA=1 in your local.conf

Best regards,

Hi @henrique.tx ,
Thank you for your advices. I have updated the manifest and did a repo sync to get the last version of the recipes from Toradex. I also included ACCEPT_FSL_EULA=1 in my local.conf.

Everything worked fine and I did get the image build.

Thank you very much for the support and your good sight!!!

Best Regards,

Hi @aarribas!

The ACCEPT_FSL_EULA=1 tip was from @joao.tx’s eagle sight :eagle: :stuck_out_tongue:

Thanks for the feedback! We are glad it worked out for you!

Please don’t forget to mark the most suitable message here as the solution, ok?

Have a nice day :smiley:

Best regards,

1 Like