Bitbake error in compiling

I tried to compile linux image 2.8 in open embedded with QT5 recipe. I almost succeed but got error at end. i am using ubuntu 16.04 32bit os. Please take look my log.

1.Inside open embedded i can’t able to make menuconfig, it raise error.

   MACHINE=colibri-imx7 bitbake -c menuconfig virtual/kernel

error:menubox.c:(.text+0xaa8): undefined reference to `wnoutrefresh’

2.And then I tried to revert back linux image 2.8 to 2.7 using repo -init. and repo sync. then i got checkout.

   error:layers/meta-toradex-bsp-common/:meta-toradex-bsp-common.git checkout

Any suggestion.

hi technomed

can you send your local.conf file and summarize all changes you have done for your compilation?

Thanks and best regards

I just add machine name and qt layer in local.conf. And I added display timing parameters in arch/arm/boot/dts/imx7-colibri-eval-v3.dtsi file. Its just a plain build .
My local.conf file.

your dtsi file seems to contain some errors . Can you send the log.do_compile.22215 file and dtsi file?

Dtsi file is not problem we just added timing parameter but we tried with default dtsi file but got same my custom dtsi file and log.do_compile.22215

Please note that as already discussed on this very community forum several times before 32-bit OS’ have long since been obsolete for cross compiling Qt5. Please update to a suitable build machine and try again.

Ok thanks you, how to solve these git check out problem when switch over linux 2.8 to 2.7.