Bitbake console-tdx-image and Cannot Fetch Linux Kernel Properly

My problem description is almost identical to @lroundy’s problem.

repo init command:

repo init -u -b LinuxImageV2.8
bitbake -k console-tdx-image

I have run this bitbake command many times without a problem. Starting yesterday bitbake got stuck on the do_fetch tasks on the following recipes:


Eventually, the two u-boot-toradex fetches completed successfully, but the linux-toradex fetch never completed. As with lroundy’s experience, the bitbake fetch progress bar filled with ‘#’ to 95% but the lessthan-equals-greaterthan symbol slid back and forth in the progress lane forever, with no progress at all.

After more than an hour, the human timeout kicked in, because I thought something was wrong. I pressed Ctl-C once, got the “wait a minute while I complete this fetch in progress” message, and then pressed Ctl-C a second time.

I have a second bitbake project on my workstation, so I tried the same command

bitbake -k console-tdx-image

in that project, and got the same result.

I decided to try just fetching linux-toradex. When I ran the commands:

bitbake -c clean linux-toradex
bitbake linux-toradex
bitbake -c cleansstate linux-toradex
bitbake linux-toradex
bitbake -c cleanall linux-toradex
bitbake linux-toradex

the BitBake output was always something like this:

Initialising tasks: 100% |#############...###| Time: 0:00:000
NOTE: Executing SetScene Tasks
NOTE: Executing RunQueue Tasks
Currently  1 runnning tasks (306 of 614)   49% |############### ...         |
0: linux-toradex-4.9-1.0.x+gitAUTOINC+07d40f6ffc-r0 do_fetch (pid 8036)  |   <=>    |

Running strace on the PID for the do_fetch returned this output:

$ sudo strace -p 8036
strace: Process 8036 attached
select(18, [15 17], [], [], {0, 225870}) = 0 (Timeout)
wait4(8283, 0x7ffd0996fec4, WNOHANG, NULL) = 0
select(18, [15 17], [], [], {1, 0})     = 0 (Timeout)
wait4(8283, 0x7ffd0996fec4, WNOHANG, NULL) = 0
select(18, [15 17], [], [], {1, 0})     = 0 (Timeout)
wait4(8283, 0x7ffd0996fec4, WNOHANG, NULL) = 0
select(18, [15 17], [], [], {1, 0})     = 0 (Timeout)
wait4(8283, 0x7ffd0996fec4, WNOHANG, NULL) = 0

NOTE: While I was trying to replicate the problem in order to write this question, ‘bitbake linux-toradex’ suddenly slipped out of stuck mode and started working. I was about to delete this question, but the fetch got to about 34%, and then slipped back into this stuck mode. I now have the following new entries in my ‘downloads’ directory:

$ ll *linux-toradex*
-rw-rw-r-- 1 rdepew rdepew 1586575429 Jan 10  2018
-rw-rw-r-- 1 rdepew rdepew          0 Sep 28 08:01
-rw-rw-r-- 1 rdepew rdepew          0 Sep 28 07:25

but the ‘fetch’ is still stuck.

I am having a similar issue:

I am trying top do a fresh bitbake for the Colibri i.MX7. It has been stuck here for about a day:

0: linux-toradex-4.9-1.0.x+gitAUTOINC+07d40f6ffc-r0 do_fetch (pid 2262) | <=> |

Yes, we are currently facing an issue with our second git server at which usually serves the Americas via global DNS at While we look into the issue you may temporarily switch to using our primary git server at located in Europe.

We got the issue resolved and all our git servers should be back to operating normally. Should you face any further issues please do not hesitate to contact us again.
Thank you very much to have brought this issue to our attention.

Thank you for your quick attention to this matter. It looks like the server came back online around 00:48 on Sep 29, and all of the do_fetch tasks completed successfully.

Perfect that it works. Thanks for the feedback.