Bitbake angstrom-qt-x11-image custom font recipe failed

I am trying to add a font to the image generated with bitbake -k angstrom-qt-x11-image but it fails with do_rootfs.
I already had the image compiled and working and the only thing I added was the following:

In local.conf :

IMAGE_INSTALL_append = "ttf-ubuntu-font-family"
PACKAGECONFIG_FONTS_append_pn-qtbase = "fontconfig"

And when I run bitbake -k angstrom-qt-x11-image it fails with this output:

Collected errors:
 * opkg_install_cmd: Cannot install package ttf-ubuntu-font-family.

BUG: Function failed: do_rootfs
BUG: Logfile of failure stored in: /home/fer/oe-core/build/out-eglibc/work/colibri_t20-angstrom-linux-gnueabi/angstrom-qt-x11-image/V2.3-r0/temp/log .do_rootfs.114257
ERROR: Task 7 (/home/fer/oe-core/build/../stuff/meta-toradex/recipes/images/, do_rootfs) failed with exit code '1'
NOTE: Tasks Summary: Attempted 5569 tasks of which 5553 didn't need to be rerun and 1 failed.
NOTE: Writing buildhistory
No currently running tasks (5569 of 5573)

Summary: 1 task failed:
  /home/fer/oe-core/build/../stuff/meta-toradex/recipes/images/, do_rootfs
Summary: There were 11 WARNING messages shown.
Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

The recipe already existed within /oe-core/stuff/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts, I just added it to local.conf

If I run:

bitbake -C compile ttf-ubuntu-font-family
bitbake -C fetch ttf-ubuntu-font-family
bitbake -C install ttf-ubuntu-font-family

seems to finish succesfull.

Any ideas?


Hi @devius!

I see you’re building an image based on BSP 2.3. Are you using the -next branch?

Additionally, does the log mentioned in the error ( /home/fer/oe-core/build/out-eglibc/work/colibri_t20-angstrom-linux-gnueabi/angstrom-qt-x11-image/V2.3-r0/temp/log .do_rootfs.114257 ) provide any more info?

Since the font recipes compile successfully by themselves, the first thing I suggest you is to run bitbake angstrom-qt-x11-image -c cleanall -c cleansstate and try building again.

Also, sometimes OpenEmbedded can be a bit picky with syntax, so I suggest replacing

IMAGE_INSTALL_append = "ttf-ubuntu-font-family"
PACKAGECONFIG_FONTS_append_pn-qtbase = "fontconfig"


IMAGE_INSTALL_append = " ttf-ubuntu-font-family"
PACKAGECONFIG_FONTS_append_pn-qtbase = " fontconfig"

Note the leading spaces before the recipe names. I often find it’s required when using _append.