Beginning of audio truncated

When pulseaudio plays back an audio WAV file (using paplay or through Qt) in the Apalis evk, the first ~0.5 seconds of the file are truncated. The same wav file is played fine in an Ubuntu 16.04 VM.

The closest incident that I can find from internet is this one: End of audio being truncated · Issue #67 · Arkq/bluez-alsa · GitHub

Have you folks encountered this issue before?

hi @mlai

Welcome to the Toradex Community!!!

Could you provide the version of the hardware and software of your module? Which carrier board are you using? Which audio output are you using? Could you provide an example WAV file to test? Thanks.

link text

It’s Apalis iMX6 and the Apalis Evaluation Board. We connect the DVI to a HDMI monitor with speaker and play the audio there. We use the angstrom qt x11 image

bitbake -k angstrom-qt5-x11-image

Thanks for the answer. Could you provide also the software version ( cat /etc/issue )?

Angstrom v2017.12 - Kernel

Apalis-iMX6_Qt5-X11-Image 2.8b2 20180609

More funky test results: we tried aplay and

  • the audio plays fine to the headset
  • the audio again misses the beginning 0.5 sec when played to the DVI → HDMI output

To what exact funky make/model of an HDMI screen?

Faytech 13" touch monitor.

I think it’s not a Toradex issue. We’ve tried another embedded Linux product (Wandboard) and got the same missing beginning 0.5 seconds when playing the audio to the same touch screen monitor through the HDMI connection. It smells like HDMI issue, or Faytech touch monitor issue.

Thanks for letting us know. I guess you may try working around it by initially playing a short unmute sequence before the actual WAV.