Audio not playing while using Gst play and Gst launch commands

Dear Sir,

We are able to play wave files using aplay command,but we are not able to play using Gstreamer commands,we are getting below errors while playing

fsl-sai 202c000.sai: ASoC: can’t set 202c000.sai hw params: -22.

fsl-sai 202c000.sai: failed to derive required Tx rate: 1411200.

we tried the same in IMX6ULL and imx7d but we are getting the same error.

please suggest us the solution how to resolve it.

Thanks & Regards,

Hi @chandrashekar

Welcome to Toradex Community.

I quickly tested with the below GStreamer command and it is working.

Test setup

Colibri imx7d and colibri evaluation board with tlv320aic32x4 codec

software :BSP5.3 with kernel v5.4

gst-launch-1.0 filesrc location=test.wav ! wavparse ! audioconvert ! audioresample ! alsasink device=hw:0,0

Dear Associate,

Thanks for your support in the short span of time,Now it is working fine .

Thanks & Regards,

Hi @chandrashekar

Glad it worked.Thanks for the update.