Attempt to enable arm32v7 emulator on Linux: Permission denied...!

Installing Toradex tools into Ubuntu VM on my MacBook.
Following instructions from this webpage:

Everything seems fine up thru addgroup (including verifying HelloWorld App).

Then, attempting to enable ARM emulation, per instructions:

parallels@ubuntu-linux-20-04-desktop:~$ docker run --rm -it arm32v7/debian arch
docker: Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post “http://%2Fvar%2Frun%2Fdocker.sock/v1.24/containers/create”: dial unix /var/run/docker.sock: connect: permission denied.
See ‘docker run --help’.
parallels@ubuntu-linux-20-04-desktop:~$

docker run --help. … did not seem very helpful.

Is there a way to get this to succeed?

Thanks!
Paul++

Greetings @Paul,

Typically this permission error occurs when trying to use Docker without the right permissions. There are two main ways around this:

  • Run every Docker command with sudo
  • Add your user to the docker user group.

Our article you linked has you do the second method. Though you mentioned you did do this addgroup command already.

Did you make sure to logout/login so that this change was applied by the system? If you run the groups command do you see the docker group in the output list?

Best Regards,
Jeremias

Jeremais,

Thanks, that was a helpful answer. Yes, I had added my username (as per website instructions).
Using sudo is what allowed the command to work…!

Now, I’m moving forward with installing Visual Studio

Many thanks!
Paul++

Glad I was able to assist.

Jeremias,

I installed VS and then installed the Toradex Extension … but hit a snag
Apparently I need to first install and run the Docker Deskptop in the Ubuntu VM

Yet, when I DL/Install as per instruction from Docker:

parallels@ubuntu-linux-20-04-desktop:~/Downloads$ sudo apt-get install ./docker-desktop-4.9.1-amd64.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘docker-desktop:amd64’ instead of ‘./docker-desktop-4.9.1-amd64.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
docker-desktop:amd64 : Depends: docker-ce-cli:amd64 but it is not installable
Depends: libseccomp2:amd64 but it is not installable
Depends: libcap-ng0:amd64 but it is not installable
Depends: pass:amd64 but it is not installable
Depends: libgtk-3-0:amd64 but it is not installable
Depends: libx11-xcb1:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.

I think for this VM, I would need a Docker Desktop DEBIAN Pkg that is using arm64, yes?
I can only find amd64.

Do I need to be looking elsewhere for the right architecture package?

Thanks,
Paul++

When working with Linux or a Linux VM in your case, Docker Desktop is not required, just the Docker engine will suffice.

Furthermore judging by your command line it looks like you’re running an Ubuntu 20.04 VM correct?

According to the Docker Desktop installation page: Install Docker Desktop on Ubuntu | Docker Documentation

Have a 64-bit version of either Ubuntu Jammy Jellyfish 22.04 (LTS) or Ubuntu Impish Indri 21.10. Docker Desktop is supported on x86_64 (or amd64) architecture.

Therefore I don’t think your version of Ubuntu is even compatible with Docker Desktop.

In any case just try installing the Docker Engine: Install Docker Engine on Ubuntu | Docker Documentation

For Linux the Docker engine is sufficient for Toradex use cases.

Best Regards,
Jeremias

Jeremais,

Thanks for the clarification.
I think I do have Docker Engine running….this looks successful:

Jeremais,

To be clear….I did do the steps to enable the Docker Engine for my username.
So, I can get the same result when running "docker run hello-world” without “sudo”

Yet, I still get the same error from VS when installing the Toradex Extension

Paul++

Jeremias,

I persisted a bit and I think I have succeeded in installing the Toradex extension
…needing some LogOut/LogBackIn help before it worked.

Thanks,
Paul++