Artifacts on LVDS display Colibri imx8x

Hi,
I’m having trouble displaying boot2qt a lvds screen, it works flawlessly on Torizon, but not when building on Yocto Zeus.
I’ve attached the screen datasheet and the my custom dts.
I’m not sure if this is a specific problem with this bsp or if I’m making some silly mistake in my dts.


DS_RVT70HSLNWC00-B_Rev.-1.0 (2).pdf (2.0 MB)
ex.dts (2.8 KB)

Colibri iMX8X
Linux BSP 4.14.x
Custom Carrier

Greetings @jhowrez,

Based off the image you provided it looks like the timings are more or less correct, rather there’s an issue with color. I have some questions however.

If the display worked flawlessly with Torizon then when not stick with Torizon? Or at least our BSP 5.0 (dunfell) which Torizon is based off of? Is there a reason you have to go back to this old Zeus-based BSP?

Looking at your device tree I don’t see anything obviously wrong. It looks like you already based it off our reference device tree here: fsl-imx8qxp-colibri-lvds-single-eval-v3.dts « freescale « dts « boot « arm64 « arch - linux-toradex.git - Linux kernel for Apalis and Colibri modules

With that said again no obvious issues. Though there may be unknown issues/bugs with our Zeus based BSP. We dropped our support for our 4.X/Zeus BSP rather quickly, so it’s not as polished as some of our other official releases. I would suggest at least moving to our 5.X/Dunfell BSP if possible. Seeing as you have already proven that this display works there with Torizon.

Best Regards,
Jeremias

Hey @jeremias.tx , thanks for the reply! Just did that and I updated to this manifest file v5.15.7-lts.xml - yocto/boot2qt-manifest.git - Unnamed repository; edit this file 'description' to name the repository.
Now, I tried flashing the newly built tezi image and I noticed two issues:

  1. The overlays folder was not copied to the boot directory
  2. My screen is black, only the backlight seems to be working.

Oh I see you’re building using the boot2qt manifest. I thought you were using something closer to our default Yocto BSP.

This certainly complicates factors since the boot2qt BSP only inherits some things from our BSP and not everything. For example the support for overlays doesn’t seem to be available as you’ve already noticed. You’ll probably need to do a device tree patch then rather than an overlay then. Finally I assume the screen is black since the default device tree doesn’t have LVDS enabled.

First try transforming your overlay changes into a code-patch that can be applied in Yocto. Then see if you can get the same functionality you got when using Torizon. Torizon uses the same kernel/device-trees as our dunfell BSP, so there should be no difference. However, there may be some other things that the boot2qt BSP changes that I’m not aware of.

Best Regards,
Jeremias

Hey @jeremias.tx , thanks for the help so far. Turns out the issue was at a manufacturing, a reflow seems to solved the issue.

Glad you were able to resolve this, would have been difficult for me to notice such an issue from my side haha.

Best Regards,
Jeremias