App not running

Hi,
I tried to deploy my app today, but no chance.

I took a new Colibri iMX7D, plugged it in an Iris Board 1.1, found out, that direct connecting a DVI monitor (hp, not a no name) to the Iris board results in a dark black screen and ‘fixed’ it by connecting the same monitor via VGA cable and DVI-VGA adapter …
Than I was not able to download the image list, I always get timeouts. Network connection looks ok, because I get an address. I changed the configuration of my router (= DHCP server) so I get another address, and now it works out. Funny, but who cares.

I installed WEC2013 V1.2, works.

I was able to boot the OS, and do all the settings (region, time, date, …) and also copied VNC to the device together with my app.

VNC starts, my app not.

I tried to manually start my app, nothing happens, no error, no dialog box, nothing.

In my desparation I prepared the development environment (VS2015) to deploy the app after compilation as I did many many times before on my development hardware.

Now I get a message telling me that my app can’t be startet, no explaination why.

Ok, my development module runs WEC2013 1.2b4 is this the problem?

If so I need help:

How can I change the two modules running V1.2b4 to run V1.2 and what is to do within VS2015 to debug or run my app on this OS image. The app is ok, by the way.

Or how can I alter the modul running V1.2 now so it runs V1.2b4? Not that good, but …

Thanks for helping.

With best regards

Gerhard

WEC2013 requires Visual Studio 2012 or Visual Studio 2013. The Community Edition of Visual Studio will work too. The Community Edition is free in many cases (see terms for details).
Application debugging is done via Ethernet connection.
Please check our article - https://developer.toradex.com/knowledge-base/getting-started-with-toradex-arm-modules#windows-ce