Apalis UART2 glitches , but UART3 and UART4 work perfect

Hi, i am trying to communicate the mighty apalis board with various microcontrollers trough serial ports.

I developed my code using UART3/4 and everything worked flawlessly, life was good.

After placing a rs232–ttl converter…(because uart2 TTL is not accessible in the ixora board),
when i try to use UART2, sometimes works sometimes it doesnt and sometimes works only two or three seconds before crashing completely my qt program.


Maybe there is a permission issue with qt?, i only have root user in my board.
[upload|n/Qz1sUymqoCzawdS65NL5uJ4Vg=]
[upload|RyyOV6Us1fPnqYwZMLsQ3Byua2Q=]


When the QT programm crashes after working perfect for two/three seconds receiving correct data it shows this error message:
[upload|xEveZdvYvyDmVdyYoXBS5hK4qyE=]

from this error handle function
[upload|0hPCY1HrsUwFxwDS2+ei48SM47A=]

the serial port was opened like this
[upload|vL0cfcb5ZEQbaQESocRgNidh450=]

Apparently both uart1 and uart2 were used by the system.
I just deleted some getty scripts ( i think im actually destroying the system consoles)

Now it works with UART2 sometimes (there is like a 50% chance) but it doesn’t crash anymore, uart1 is still not available.
I took the idea from here:
https://www.toradex.com/community/questions/15421/how-i-can-change-u-boot-console-to-uart2-on-apalis.html

After placing a rs232–ttl converter…(because uart2 TTL is not accessible in the ixora board)

Actually UART2 TTL signals RX/TX/RTS/CTS are available on X21 Ixora connector. Could you please provide more details about your rs232–ttl converter wiring?

UART1 is used as a debug port and as a default Linux text console.

Hi i cant find the ttl pins in the x21 connector
[upload|/18pjJ7NXYj2ABwhEZu2SZ8HYDA=]

My wiring is detailed as follows:
[upload|Q56lPt5Mk/xJ0//QKr2wVKFHwR8=]
[upload|B3WR06ahWu0skFuWX3frYmQC3PE=]

Something else is still using the UART2 because it still crashes after some time (much better than before)

thanks, i wont use UART1 then.
But it would be very handy to be able to use UART2,

Hi @javiernicola,

Is your issue solved or you need more support on this topic?

Best regards,
André Curvello

Hi, the UART2 is still being used somewhere in the system making my programm glitch, is there any way to make the uart2 available only for the user programm and not the system?

When i erased those system scripts the uart2 now is less interrupted and less glithing but there is still some frugal interruptions.

Yes, you are rite, Only RS232 levels available on Ixora for UART_B. Since you are using only RX/TX signals you should disable HW flow control for UART_B

Toradex provided Linux and Torizon images do not use UART2 internally. QT image you are using is built by QT and it could be used for some other purpose. Please consult with QT documentation. To be sure that HW works as expected I’d recommend to install Toradex Linux image and test serial ports.

okay, i just opened a ticket with qt and i will post here their reply.
thanks

Thanks for update. Could you please forward their reply to us as well?