Apalis-TK1 Yocto Build Fails w/Bad mozjs Checksum


I’m following the Yocto build tutorial provided by Toradex, except building the Apalis TK1 LXDE image instead of a Colibri-iMX6. I’ve run into the following error:

ERROR: mozjs-17.0.0-r0 do_fetch: Checksum failure fetching http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
ERROR: mozjs-17.0.0-r0 do_fetch: Fetcher failure for URL: 'http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz'. Checksum mismatch!
File: '/home/feln/yocto/build/downloads/mozjs17.0.0.tar.gz' has md5 checksum a34f6b4ee8cf0da8283e54e1ccac770e when 20b6f8f1140ef6e47daa3b16965c9202 was expected
File: '/home/feln/yocto/build/downloads/mozjs17.0.0.tar.gz' has sha256 checksum df7f2769da3ef21eced723eba774521629a0109b45f0831e4117835ccb355a8c when 321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba was expected

Things I changed from the stock tutorial:

  • In local.conf I commented the default machine and uncommented MACHINE ?= "apalis-tk1"
  • In local.conf I added ACCEPT_FSL_EULA = "1"
  • repo init -u http://git.toradex.com/toradex-bsp-platform.git -b LinuxImageV2.8 (instead of 2.4) followed by:
  • repo init -u http://git.toradex.com/toradex-bsp-platform.git -b refs/tags/Apalis-TK1_LXDE-Image_2.8b6.184-20190401

Steps I’ve tried:

  • repo sync immediately before build.
  • Changing the sha256 checksum in the mozjs_17.0.0.bb file (this leads to a different error).

Am I missing something else here? I did a bit of googling and someone mentioned this could be a repackaging issue upstream. If anyone has run into this before any help would be appreciated. At this point I’m thinking of just trying to remove the layer since I don’t need it anyway, but I was hoping to get the stock tutorial complete before customizing.

Edit: I also tried following the tutorial exactly, and got the same error for the same file.


Doing the download manually leads to correct checksums for me:

$ wget http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
--2019-06-05 09:34:19--  http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
Resolving ftp.mozilla.org (ftp.mozilla.org)...
Connecting to ftp.mozilla.org (ftp.mozilla.org)||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6778934 (6.5M) [application/x-tar]
Saving to: ‘mozjs17.0.0.tar.gz’

mozjs17.0.0.tar.gz  100%[===================>]   6.46M  40.3MB/s    in 0.2s    

2019-06-05 09:34:20 (40.3 MB/s) - ‘mozjs17.0.0.tar.gz’ saved [6778934/6778934]

$ md5sum mozjs17.0.0.tar.gz
20b6f8f1140ef6e47daa3b16965c9202  mozjs17.0.0.tar.gz
$ sha256sum mozjs17.0.0.tar.gz 
321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba  mozjs17.0.0.tar.gz

My first guess is that your download got somehow interrupted. You could try the following:

bitbake -c cleanall mozjs
bitbake mozjs



  • The last repo init invocation defines the used layer versions done in the repo sync step.
  • Note that the sha256 and the md5 checksum did change, so if you change the recipe you would need to change both.
  • Note the trouble shooting section.

Hi Max,

Thanks for the quick response, I really appreciate your help. I tried a wget as well and it cuts the download short. Turns out our firewall does not like Mozilla’s FTP! I suspect this is the root of the issue, thank you very much for bringing this up, and for pointing to the trouble shooting section. I should have tried the suggestions
first (though it wouldn’t help here). I did a bit of googling but overlooked that section.

I’ve contacted our IT dept to get the proper access allowed for the build VM, I think the toolchain will work once we sort this out.

hi @shrike92

You are welcome. Thanks for your feedback.
Let us know, once you solved the issue with your IT department.

Best regards,

thanks for this input. had the same problem solved by switching to another network where link is not blocked.

Perfect that your issue is solved. Thanks for your valuable Input.