apalis-TK1 module is freezed

Tk1 was working for like 10 min then it became frozen. when I rebooted the board, only one green light was appeared.
I had waited for sometime( minutes/ hours) then it came back to life again, running the image I had installed. worked for 10 min then get back to freeze

I am using Ixora carrier board. V1.2
with multimedia image that I built using yocto project tutorial

Have you installed a heatsink?

hi @alex.tx
yes I have.

Hi @alex.tx ,

I have Q; if it was an ESD issue with TK1, what could be the solution?
again my module is turned off now and i can not turn it on again.
suddenly it turned on for like 5 min then got back to turn off.

Hi @rama.aloufee !

Can you check if the power source that you are using is delivering enough power?

Generally, I use at least 20W capable power sources.

Best regards,

Hi @henrique.tx ,

I was using the power cable which came with accessory kit.
now I am using a power supply with 12 V and 1.5 A.
recently when it was working properly I have checked the power consumption for it while running my app; video streaming one pipeline vs two pipelines. the power does not exceed 10 W.

so I do not think it is power issue. i think it is related to the ESD problem

Hi @rama.aloufee !

ESD problems are unlikely. But, of course, you can protect against it by using ESD safe instruments (like mats for eletronics) and mainly be aware of charged devices that could be in touch with/near the module/carrier board

I also have some questions to try to find out why this issue is occurring.

  • Could you check that heatsink well mounted?
  • When it reboots, are you running something that creates a high cpu load?
  • What you have connected to the Ixora board?
    • Additional components will drain more power, so maybe the power source you are using won’t be enough.
  • Could you use an oscilloscope to monitor the input power and also the 3.3V of the carrier board?
    • What is the behavior of these signals during the reboot issue?
  • Which version of Toradex BSP are you using?

Best regards,

The peak power consumption of Apalis TK1 module itself is above 10W plus Ixora board (1.5-2W) and potential peripherals like USB, mPCIe etc. SO it’s highly recommended to use at least 2 Amp 12v power supply.

Could you check that heatsink well mounted?
yes it is

When it reboots, are you running something that creates a high cpu load?
not nessessary. rebooting and doing nothing is enough for turn it off again.

What you have connected to the Ixora board
nothing, i am using ssh via Ethernet cable
PS: I used to use USB hub for mouse and keyboard but now stopped to avoid any extra problems

Could you use an oscilloscope to monitor the input power and also the 3.3V of the carrier board?
it is turned off 3 days ago and did not get back to work.

Which version of Toradex BSP are you using?
BSP5, multimedia reference image

noted with thanks

Hi @rama.aloufee

it is turned off 3 days ago and did not get back to work.

Seems like it is still not working, right?

Did you manage to reset/recovery it? Maybe reinstall the SO?

After recovering, using a power source like alex.tx said (12V/2A) results in the same freezing/shutdown problem?

Best regards,