Apalis TK1, JetPack with L4T and custom Linux Kernel - Broken

I’ve followed to the letter the article which gets NVIDIA’s JetPack with L4T running on the TK1:

http://developer.toradex.com/knowledge-base/installing-nvidia-jetpack-with-l4t-on-apalis-tk1

This was working perfectly, with Ubuntu running smoothly. Initially there were some configuration issues getting the LVDS display to work correctly however this was resolved and it all just worked.

I then followed the “Building Linux Kernel from Source” section of the article so I could add in support for the ADV7280, Wi-Fi, I2C devices, etc, etc and following compilation, deployed my new kernel (and L4T rootfs) to the target.

Unfortunately now, I’m stuck with a number of issues:

The “ubuntu” auto login no longer works and the debug console reports many “Authentication failure” messages before it no longer accepts any character input - I’m not able to try logging in as root or any other account as the console won’t accept anything.

Likewise, if I look at the display, I’m presented with a “The system is running in a low-graphics mode” and a number of recovery options - all of which either do nothing or cause the system to eventually freeze.

Have any of the Toradex team experienced this kind of behaviour? All steps in the article were covered.

While we don’t usually use the likes of Ubuntu I do not recall having ever seen any such behaviour. Could you please post the full serial console boot log as we may spot what is going wrong in there.

Hi @marcel.tx, unfortunately I’m unable to copy the full content of the boot log here as it exceeds the character limit but rather, I’ve attached it to this message.

debug log

Can you share the .config file of your kernel?

Hi @dominik.tx, here’s the .config file:

config

I had to remove the ‘.’ prefix as the uploader didn’t seem to like it.

I could not find much unusual neither in your .config nor your debug output. Probably something rather Ubuntuish went wrong. I would suggest re-installing.

Hi @marcel.tx, I’ll have a go at re-installing this morning. I’ve got a feeling the same thing will happen though but its worth a try.

Is there any way I can prevent the auto-login kicking in for the “ubuntu” account? Presumably there is some config file in the rootfs which would allow me to disable this?

We are not really Ubuntu experts. I guess Google is your friend.

Hi @marcel.tx, no problem - thanks for your help. I’ve managed to recover the Ubuntu issue I was having and now I’m up and running again.

One thing that has since stopped working is the Wi-Fi management on the Ubuntu desktop. I have a wlan0 device and ifconfig iwlist scan and other utilities show it is working yet Ubuntu thinks otherwise.

I’ll figure it out although I’m beginning to find that with Linux, there are many ways to skin the same cat yet not all of them work without some kind of tinkering!

Yes, agreed. Which on itself does not need to be a bad thing as one can at least thinker unlike on some of them proprietary systems.

Hi @kwebster83,

I encounterede with the same problem, after booting my Apalis TK1, I stucked at following loop

tegra-ubuntu login: ubuntu (automatic login)

Authentication failure

Ubuntu 14.04.1 LTS tegra-ubuntu tty50

I was checking boot log but I did not see any crucial thing.
boot log