Apalis-imx8qm b2qt qtwebengine build error

Hello everyone,
I get an error when compiling the B2qt image.

ERROR: Task (/home/pc_742/Toradex/Yocto_Images/bt2qt_son/meta-boot2qt/sources/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_compile) failed with exit code '1'

When I follow this document ( How to set up Qt Creator to cross compile for embedded Linux | Toradex Developer Center ) after compile process started, I’ve belowed error. In attached you can find the detailed log files.Error Log File

| ninja: build stopped: subcommand failed.
| Makefile.gn_run:365: recipe for target 'run_ninja' failed
| make[3]: *** [run_ninja] Error 1
| make[3]: Leaving directory '/home/pc_742/Toradex/Yocto_Images/bt2qt_son/meta-boot2qt/build-apalis-imx8/tmp/work/aarch64-mx8-poky-linux/qtwebengine/5.15.0+gitAUTOINC+387fb9377d_623647821a-r0/build/src/core'
| Makefile:82: recipe for target 'sub-gn_run-pro-make_first' failed
| make[2]: *** [sub-gn_run-pro-make_first] Error 2
| make[2]: Leaving directory '/home/pc_742/Toradex/Yocto_Images/bt2qt_son/meta-boot2qt/build-apalis-imx8/tmp/work/aarch64-mx8-poky-linux/qtwebengine/5.15.0+gitAUTOINC+387fb9377d_623647821a-r0/build/src/core'
| Makefile:78: recipe for target 'sub-core-make_first' failed
| make[1]: *** [sub-core-make_first] Error 2
| make[1]: Leaving directory '/home/pc_742/Toradex/Yocto_Images/bt2qt_son/meta-boot2qt/build-apalis-imx8/tmp/work/aarch64-mx8-poky-linux/qtwebengine/5.15.0+gitAUTOINC+387fb9377d_623647821a-r0/build/src'
| Makefile:48: recipe for target 'sub-src-make_first' failed
| make: *** [sub-src-make_first] Error 2
| WARNING: exit code 1 from a shell command.

Do you have any suggestion ?

Best regards

Hi @yusufsatilmis

qtwebengine is unfortunately a beast… So one way to get rid of the error is to disable the webeninge. I think this can be done in local.conf with:

DISTRO_FEATURES_remove = "webengine"

As far as I know older distributions also have an issue with compiling it. So e.g. an update to Ubuntu 18.04 could help. Another issue that can lead to the problem is if you don’t have enough memory the build process gets killed. If you see somewhere oom messages this would be the problem.


Hi @yusufsatilmis , @stefan_e.tx is right that memory is the issue. I raise my builder server memory from 12GB to 18GB then successfully build Qt5 with webengine. If it is not needed in your project, just remove it.

I have 32 GB of memory on my computer. I don’t think it’s the problem.
But I removed it because I did not use it in my project. The compilation was completed in this way.

Best Regards


Perfect that it works. Thanks for the feedback.