Apalis IMX8 vscode, qtproject build failed

I’m following Qt C++ Application Development on Torizon Using Visual Studio Code tutorial to run a simple qt application on my Toradex machine but when I try to build the project I’ve faced the below error:

command 'torizon.ccpp.getTargetFolder' not found

I’ve setup my vs code, installed the extensions, docker is running and no other error is happening.

Greetings @farshid616,

Just some clarifying questions before we investigate this.

  • Are you running the VSCode extension
    on a windows or linux machine? This
    shouldn’t make a difference but we
    just want to make sure.
  • Which Qt project template did you use for the project?
  • Can you share the code you used? Or did you just use the default code that came with the project template?
  • Finally did you do any other steps or was it simply just creating the project and then starting the build/debug process.

Once you provide this additional information I can try to attempt to reproduce on my side and let you know what I find.

Best Regards,

Dear @jeremias.tx

I’m running VSCode and related extentions on ubuntu 18.04, I used Qtwidget example, and I’ve tried to build and debug the default source code without modifying anything.

Best Regards, Farshid

Problem solved, It was just a permission conflicting.

Oh okay, that’s good to hear you resolved it then. If you don’t mind could you share exactly what was the conflict, and what you did to resolve it. In case someone has a similar issue in the future.

Best Regards,

1 Like

Hy @farshid616
I am facing the same problem after rearranging my sourcefiles.
How did you solve your permission conflict?

Thank you,

Hi @Zag , I sometimes run into the similar issue. A reloading fixes it. Press F1Developer: Reload Window.

1 Like

Hi @Zag

This problem was for a long time a go and I can’t remember completely. I remember running with sudo and some changing ownership with sudo chown unfortunately I can’t remember what should be change or run with permission exactly.