Apalis iMX8 ping by hostname


I have a problem on my apalis-imx8, everithing that has to do with local hostname does not work.

I have tried this:

  • from windows → ping → works great

  • from windows → ping b2qt-apalis-imx8 → does not work

  • from windows → ping my-second-windows-pc → works great

  • form iMX8 → ping → works great

  • from iMX8 → ping my-windows-pc → does not work

  • from iMX8 → ping google.com → works great

I have a custom Boot2Qt image based on my custom meta-layer. So how could I make it work natively by configuring it via my meta-layer? like enabling DNS or something?

Thanks for your answers!

Is avahi running? Than add .local after host name. Whatever you renamed it to like myhost + .local.
ping myhost.local

I don’t have avahi on my distro

And adding .local doesn’t do anything, I still have a “bad address 'my-windows-pc.local”

I meant if your Apalis/Colibri hostname is b2qt-apalis-imx8, it should be pingable from Windows 10 pinging b2qt-apalis-imx8.local. If you have several Colibries with the same name, only one of them will resolve on Windows to this name, others will be named uniquely by Avahi adding -2, -3, etc to host name like b2qt-apalis-imx8-2.local.

Usually Windows resolves other Windows machines in two ways. a) some DHCP servers add client machine name to local DNS servers. b) WINS. For a) check your router, some SOHO routers implement it out of the box, others are not able to do it. For b) you may use Samba.

Still, this does not work.

I have only 3 devices on this local network for dev purpose (my-windows-pc, b2qt-apalis-imx8 and synology-nas). I am fully able to ping my-windows-pc and synology-nas in both direction by hostname with or without .local, but as soon as I try something with b2qt-apalis-imx8 it doesn’t work even with .local. the only way to ping my apalis board is with the IP address. And vice-versa, the only way for the apalis board to ping the synology-nas or the windows-pc is with the IP address.

P.S. this local network has full access to the web through a simple cisco router that manage the local network.

Hi @Romain.Donze

This is a misconfiguration in your local Network regarding DHCP and DNS. We cannot help you on this.

Best regards,

Hi @jaski.tx ,

In fact, we arrived to this conclusion no later than yesterday :wink: and we just had to configure a dns server on the Synology-Nas of our local network to make it work.

Problem solved!

Perfect that your issue is solved. Thanks for the feedback.