Apalis iMX8 no wifi

Dear Community,

I have and Toradex Apalis iMX8QM V1.1C 4GB WB IT and an Ixora 1.1A. Although my iMX8 is a WB version, I can’t find any wifi interfaces.

iw dev

and

nmcli device wifi list

commands don´t show anything. However, it seems that wifi modules are loaded:

root@localhost:~# lsmod
Module                  Size  Used by
snd_soc_imx_cdnhdmi    16384  0
crct10dif_ce           16384  1
mwifiex_pcie           45056  0
snd_soc_hdmi_codec     20480  1 snd_soc_imx_cdnhdmi
mwifiex               294912  1 mwifiex_pcie
cfg80211              393216  1 mwifiex
rfkill                 36864  2 cfg80211
ahci_imx               28672  0
flexcan                32768  0
can_dev                36864  1 flexcan
mxc_jpeg_encdec        36864  0
cdns_mhdp_imx          40960  0
ip_tables              32768  0
x_tables               40960  1 ip_tables

root@localhost:~# uname -a
Linux localhost 5.4.129-37371-gc99d3f9d208b #1 SMP PREEMPT Wed Oct 27 11:07:21 CEST 2021 aarch64 aarch64 aarch64 GNU/Linux

How can I bring up the wifi interface?

Thanks in advance,

Ander.

Hi,

Any updates on this?

Best regards,

Ander.

Hi @Andermutu !

From your command lines, seems like you built your own image using Yocto (root@localhost). Is that right? The reference images present the module type and serial number at the beginning of command lines.

I took an Apalis IMX8QM v1.1B 4GB WB IT and installed the Reference Minimal Image 5.4.0+build.11 (dunfell). nmcli is not available, but here is what I got.

Using iw:

root@apalis-imx8-06804757:~# iw dev
phy#0
        Interface uap0
                ifindex 6
                wdev 0x2
                addr d8:c0:a6:cf:7a:4f
                type AP
                txpower 0.00 dBm
        Interface mlan0
                ifindex 5
                wdev 0x1
                addr d8:c0:a6:cf:78:4f
                type managed
                txpower 0.00 dBm

Using lsmod:

root@apalis-imx8-06804757:~# lsmod
Module                  Size  Used by
rfcomm                 61440  2
8021q                  36864  0
btusb                  53248  0
btrtl                  20480  1 btusb
btintel                24576  1 btusb
btbcm                  20480  1 btusb
bluetooth             405504  30 btrtl,btintel,btbcm,btusb,rfcomm
ecdh_generic           16384  1 bluetooth
ecc                    32768  1 ecdh_generic
mwifiex_pcie           45056  0
mwifiex               294912  1 mwifiex_pcie
snd_soc_imx_cdnhdmi    16384  0
snd_soc_hdmi_codec     20480  2 snd_soc_imx_cdnhdmi
crct10dif_ce           16384  1
cfg80211              393216  1 mwifiex
rfkill                 36864  7 bluetooth,cfg80211
ahci_imx               28672  0
flexcan                32768  0
can_dev                36864  1 flexcan
mxc_jpeg_encdec        36864  0
cdns_mhdp_imx          40960  0
libcomposite           69632  0
configfs               53248  2 libcomposite

Using connmanctl:

root@apalis-imx8-06804757:~# connmanctl
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Scan completed for wifi
connmanctl> agent on
Agent registered
connmanctl> services
*AO Wired                (network's id)
    reptree_back_5G      (wifi network's id)
    reptree_back_5G      (wifi network's id)
    reptree_back         (wifi network's id)
    reptree_back         (wifi network's id)
connmanctl>

You can see that it is working properly. If you really have built your own image, it is worth checking if maybe you disabled something related to the wifi. Also, take a look at the attached article that can be handy for dealing with wifi :slight_smile:

Best regards,

https://developer.toradex.com/knowledge-base/wi-fi-client#tab-bsp-5-3-and-28