Apalis iMX8 damaged?

Hardware and software

Apalis iMX8 V1.0B
Ixora carrier board 1.1A
Linux Reference Minimal Mainline based kernel


Dear Community,

While I was using an Apalis iMX8 suddenly stopped working. I usually use the x22/UART1 port to log in to the console, but after it stopped working x22 does not output anything, not even U-Boot sequence. I have replaced iMX8 SOM with a TK1 SOM and everything works as expected, so the Ixora carrier board does not seem to be damaged.

Then, I have tried to load Toradex Easy Installer on the iMX8 SOM after putting it on RCM using hardware mechanisms, with different builds (Lastest Release and Nightly Pre-Release) and different PCs (Windows and Ubuntu) with no success. I get this error:

1:1 1/ 1 [HID(W):LIBUSB_ERROR_TIMEOUT ] SDPS: boot -f …/imx-boot

or this:

1:1 1/ 1 [HID(W):LIBUSB_ERROR_IO ] SDPS: boot -f …/imx-boot

This is lsusb output after putting the board on RCM:

Bus 001 Device 046: ID 1fc9:0129 NXP Semiconductors SE Blank 8QM

Short before turning the Ixora on, power consumption is 0.35A, and after running recovery-linux.sh power consumption rises to 0.55A. Then, it does not change and the iMX8 heat sink gets really hot.

Is there something else could I try? Or is the iMX8 dead?

Best regards!


Hello, have you been able to boot the Toradex Easy Installer?
Or did this not even work? Keep in mind the Toradex easy installer will only live in RAM after running the recovery script.
Also which host system you are working on? Sometimes the module is not recognized by windows host systems. After you put the system into recovery mode make sure that the SOM shows up as an USB device at you host system.

Best Regards,

Matthias Gohlke

Hi @matthias.tx ,

I have not been able to boot the Toradex Easy Installer. recover-linux.sh script fails as shown before, and I don´t see anything through the x22 uart1 connector or HDMI display. Also, the ethernet port does not light. I have loaded Easy Installer to RAM many times with other modules (Apalis TK1, Colibri iMX6S/7), even with this Apalis iMX8, and it always has been straightforward.

I have tried in Ubuntu 18.04 and Windows 10, also with different cables and unplugging and puggling back everything. After putting in recovery the iMX8 module is recognized by Ubuntu and Windows 10 as SE Blank 8QM. However, Easy Installer stops at 20% and then I get:

1:1 1/ 1 [HID(W):LIBUSB_ERROR_IO ] SDPS: boot -f …/imx-boot

Thanks for your help!


Ok, keep in mind you are using an old early access sample 1.0B
There have been many fixes since the early access samples.
So try one more thing. When you close the recovery pins wait a bit longer after power up.
If this does not help as well please sent the module in for RMA.

Best Regards,

Matthias Gohlke


Even waiting more time to release the recovery pins short it is not possible to load Toradex Easy Installer. As you suggested, I will send the module to RMA.

Best regards,