Apalis iMX6D didn't enter recovery mode

Hi folks,

I have a Apalis iMX6D 1GB IT Board(V1.1Y) and Ixora Carrier Board(V1.3A). My host computer is Ubuntu 20.04

I successfuly examine some of demos provided by Toradex Easy Installer. But when i try to install Toradex Easy Installer(USB OTG) . it suddenly stop working and didn’t enter recover mode whatever i made.Just LED1 lights up green, there is no HDMI output.(I removed JP2 and shorted 6sec the JP4 recovery as the video described)

username@computer:~/Downloads/Apalis-iMX6_ToradexEasyInstaller_6.6.0+build.6$ ./recovery-linux.sh 
Downloading Toradex Easy Installer...
uuu (Universal Update Utility) for nxp imx chips -- libuuu_1.4.127-0-g08c58c9

Success 0    Failure 0    Wait for Known USB Device Appear...   

I also extracted the EasyInstaller .tar file to FAT32 formatted SD Card. It didn’t launch the Easy Installer

Before, when the board enter the recovery mode it dissipated 20.97V 74mA. But when it didn’t enter recovery mode this values become 20.97V 70mA.

I couldn’t see anything from my host computer(dmseg , lsusb or udevadm monitor)

I you share with me Test Point names, i’ll measure the voltages.

What i need to do?

Best regards

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!


Hello,

I understand you’re facing issues entering recovery mode with your Apalis iMX6D module on the Ixora Carrier Board, despite following the recommended steps. Given the details you’ve provided, it seems you’ve correctly attempted to enter recovery mode but without success. The change in power consumption you’ve observed when attempting to enter recovery mode is subtle and might not be directly indicative of the issue at hand.

Considering the steps you’ve already taken, including attempting to boot from an SD card without success, and the fact that there’s no response from the module (as indicated by the lack of HDMI output and no detection on the host PC), the situation suggests a deeper issue than just failure to enter recovery mode.

Here are a few additional steps you can consider:

  1. Re-check the Recovery Mode Procedure: Ensure that JP2 is removed to enable USB OTG mode and that you’re correctly shorting the recovery mode pads (JP4) for at least 6 seconds after applying power to the board. It’s crucial to follow the exact timing as described in the documentation.

  2. Inspect the Hardware: Look for any visible signs of damage or issues on both the SoM and the carrier board. Ensure that there are no short circuits, damaged components, or anything unusual with the board’s physical condition.

  3. Try a Different Power Supply: Although less likely to be the cause, ensuring the power supply is stable and within the recommended specifications is essential. An unstable or inadequate power supply can cause various issues.

  4. Check for Serial Console Output: If you haven’t already, try connecting to the board’s serial console using a USB-to-serial adapter. The serial console might provide additional output that could help diagnose the issue, even if the HDMI output is not working.

  5. Ensure the Host Machine Configuration: On your Ubuntu host, ensure that you have the necessary permissions to access USB devices and that the uuu tool is correctly recognizing devices in recovery mode. Running uuu with sudo might sometimes help if it’s a permissions issue.

  6. Voltage Measurements: While specific test point voltages are generally detailed in the module’s datasheet or hardware design guide, common points to check include the main 3.3V and 1.8V rails on the SoM. Ensure these are within their expected ranges.

If after these steps, the module still fails to enter recovery mode or show any signs of life (via HDMI or serial console), it might indicate a more severe issue with the

Please, also check if these links can help you solve your problem:

NXP i.MX and TI AM62x Recovery Mode | Toradex Developer Center.


How did you like my response?

:+1: :-1:

Hello @rdmonster,

Welcome to Toradex Community and thanks for contributing!

There are few things that you could check to identify the issue here.

  1. Do you have USB OTG cable connected from your development machine to the Ixora board (on the X9 connector - which is a micro USB port)?
  2. If the above-mentioned condition is met and you have put the module in recovery mode (by shorting the pins on JP4 as it is shown in this image), you should be able to see the device listed with lsusb command from your host PC. It should be listed as Freescale Semiconductor, Inc. i.MX 6Dual/6Quad SystemOnChip in RecoveryMode.

Hello @rudhi.tx

  1. Yes

  2. Before the this problem seen, I can able to see the device with dmesg as you described.

[10499.355511] usb 1-1: Manufacturer: Freescale SemiConductor Inc 
[10499.358136] hid-generic 0003:15A2:0054.000E: hiddev1,hidraw5: USB HID v1.10 Device [Freescale SemiConductor Inc  SE Blank ARIK] on usb-0000:00:14.0-1/input0
[10506.664650] usb 1-1: USB disconnect, device number 27
[10506.970415] usb 1-1: new high-speed USB device number 28 using xhci_hcd
[10507.119988] usb 1-1: New USB device found, idVendor=1b67, idProduct=4fff, bcdDevice= 5.00
[10507.120000] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[10507.120005] usb 1-1: Product: USB download gadget
[10507.120008] usb 1-1: Manufacturer: Toradex```

How can i put the device recovery mode?

Hello @rdmonster,

This is a strange behavior indeed!
Do you already have a serial console connected to the module? In that case, you will be able to see the logs on the terminal. This will give us more information on what is going on. You may use minicom or picocom to stay connected to the serial console.

Hello @rudhi.tx ,

Today, I connected the RS232 line through X22 on carrier board. Whatever i make , i couldn’t get any data .
How can i diagnose the problem?

What power supply are you using? Could you please send the specifications?
Also, do you have another Apalis module that you could test in this setup?

Owon SPE6103 Current limited power supply.I Unfortunutelly i didn’t have a another module .

Hello @rdmonster,

If you try to simply reboot the module, do you see any logs on the connected serial console? Even if it does not go into recovery mode, it should boot into the previous OS version installed on the module. Is that the case? How long have you been working with this module? Is this the first time that you are trying to put the module in recovery mode?

Hello @rudhi.tx ,

I couldn’t see anything from serial terminal even if i connect the it oscilloscope.
When it worked previously, board’s current consumption changed when it enter the recovery mode.
Whather recovery mode procedure or normal reset , current value didn’t change. And also just LED1 on state whatever i make

Board didn’t boot previosly installed OS .
I was working Apalis Board for a one week.
I couldn’t see anything from serial terminal(X22 conn. UART1 Apalis) even if i connect the it to oscilloscope.
When it worked previously, board’s current consumption changed when it enter the recovery mode.
Whather i made recovery mode procedure or normal reset , current value didn’t change.

This pictures taken from after recovery mode attempt.

UART1 on X22 connector

Related recovery pins shorted >6 second and remove

I also try Boot From an SD with Qt 5.12.4 Image.(Boot From an SD Card / USB Stick | Toradex Developer Center) . ı couldn’t get any data from RS232, nothing changed on HDMI output and current consumption same as previous attempts.

Just to identify if this is an issue with the Apalis module itself or with the carrier board, could you please try with another Apalis module if you have any with you?

Unfortunetelly , I don’t have a another Apalis Module.