Apalis IMX6 SGTL5000 disable audio fade in using Linux

When playing a sound from the Linux command line using play, the SGTL5000 slowly increases the bias voltage over about 400 msec. This causes the sound to fade in. If the sound is played immediately again, it plays at full volume. After several seconds of no sound playing, the SGTL5000 powers down and turns the bias voltage off again, which causes the cycle to repeat.

Is there a way to disable the powering down of the SGTL5000 using a command line option or kernal configuration so the bias voltage remains on at all times?


What exact hardware (module and carrier board) and software versions of things are you talking about? As we fixed quite some such issues over the last year or so.