Apalis IMX6 PCIe with Apalis Evaluation Board Failed to initialize host

I have a Apalis IMX6 DL 512MB with the Apalis Evaluation Board.

I am trying to use one of the PCIe 1x slots.

I do not detect any pci devices when using lscpi

I get the following error when booting:

[    0.325128] OF: PCI: host bridge /soc/pcie@0x01000000 ranges:
[    0.325169] OF: PCI:   No bus range found for /soc/pcie@0x01000000, using [bus 00-ff]
[    0.325222] OF: PCI:    IO 0x01f80000..0x01f8ffff -> 0x00000000
[    0.325255] OF: PCI:   MEM 0x01000000..0x01efffff -> 0x01000000
[    0.574983] imx6q-pcie 1ffc000.pcie: phy link never came up
[    0.575020] imx6q-pcie 1ffc000.pcie: Link never came up
[    0.578107] imx6q-pcie 1ffc000.pcie: failed to initialize host
[    0.578206] imx6q-pcie: probe of 1ffc000.pcie failed with error -110

I have used both Toradex Linux BSP 2.7 and tried the 2.8 Beta as well. I get the same error with both.

Is there something I am missing about what I need to do to get the PCIe host up and running?

Thank you.

hi Brian

Thanks for contacting the toradex support.
Could you provide the exact version of your hardware? Can you write about the conditions to reproduce the issue?

We have seen the issue once, but we could not reproduce it systematically till now. We will check for this issue and keep you updated.

jaski,

I have the Apalis IMX6D 512MB v1.1B with the Apalis Eval Board V1.1A

I just have to boot the SOM/eval board combo to get the error as it happens every boot.

Brian

That is rather strange. We have only seen it very rarely. Do you happen to have another set of Apalis iMX6D resp. Apalis Evaluation board which you may try to rule out any defective hardware?

Unfortunately, I do not have another board to test out. I will be getting an RMA.

Ok, do it.

@BTG666, short update. We did more tests in the meantime, including tests in the temperature cabinet and didn’t see such issues using our 2.8b2 BSP. We are curious to get your hardware back through RMA to check the issue further.
https://www.toradex.com/support/return-material-authorisation

@roman.tx I did do an RMA last month if you contact the Seattle office and reference RMA.US.2018042510000199 you should be able to get the hardware. I have a new board and everything is working fine on that board.

@BTG666, thanks for referencing the RMA case. We will look at this internally.